3

I dual booted my Laptop Acer Aspire E5-573 with Windows 10 and Ubuntu 15.10 and every since the first day I'm not able to use WiFi on any linux platform. I did everything I could have done still no use. No additional drivers available for me on Ubuntu but I'm perfectly able to use WiFi on Windows 10. WiFi chip in my laptop is Qualcomm Atheros QCA9377 Wireless Network Adapter. Please find me a solution for it.

    dmesg | grep ath10k
[   11.203844] ath10k_pci 0000:03:00.0: pci irq msi-x interrupts 8 irq_mode 0 reset_mode 0
[   11.599565] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/cal-pci-0000:03:00.0.bin failed with error -2
[   11.599579] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/QCA9377/hw1.0/firmware-5.bin failed with error -2
[   11.599582] ath10k_pci 0000:03:00.0: could not fetch firmware file 'ath10k/QCA9377/hw1.0/firmware-5.bin': -2
[   11.599589] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/QCA9377/hw1.0/firmware-4.bin failed with error -2
[   11.599591] ath10k_pci 0000:03:00.0: could not fetch firmware file 'ath10k/QCA9377/hw1.0/firmware-4.bin': -2
[   11.599596] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/QCA9377/hw1.0/firmware-3.bin failed with error -2
[   11.599598] ath10k_pci 0000:03:00.0: could not fetch firmware file 'ath10k/QCA9377/hw1.0/firmware-3.bin': -2
[   11.599603] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/QCA9377/hw1.0/firmware-2.bin failed with error -2
[   11.599605] ath10k_pci 0000:03:00.0: could not fetch firmware file 'ath10k/QCA9377/hw1.0/firmware-2.bin': -2
[   11.599610] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/QCA9377/hw1.0/firmware.bin failed with error -2
[   11.599612] ath10k_pci 0000:03:00.0: could not fetch firmware (-2)
[   11.599614] ath10k_pci 0000:03:00.0: could not fetch firmware files (-2)
[   11.599615] ath10k_pci 0000:03:00.0: could not probe fw (-2)
5
  • Is there a clue in the message logs? Please open a terminal and run: dmesg | grep ath10k Please edit your question to add the result.
    – chili555
    Dec 30, 2015 at 14:12
  • whenever I try sudo cp -r ath10k-firmware/QCA9377 /lib/firmware/ath10k I get sudo: unable to resolve host nachiket-acer Dec 30, 2015 at 15:20
  • Please see: askubuntu.com/questions/59458/…
    – chili555
    Dec 30, 2015 at 15:35
  • for sudo apt-get install git this is the output:- Reading package lists... Done Building dependency tree Reading state information... Done Package git is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package 'git' has no installation candidate Jan 14, 2016 at 13:33
  • I wonder why a commonly available package, git is not installable, along with all its dependencies, on your system. packages.ubuntu.com/wily/git That is a good subject for a new, separate question. I will therefor amend my answer to provide an alternate method to download and install the missing firmware.
    – chili555
    Jan 14, 2016 at 14:40

1 Answer 1

6

It appears that you need but are missing the required firmware. With a working internet connection by ethernet, tethered or whatever means possible, open a terminal and do:

wget https://github.com/kvalo/ath10k-firmware/archive/master.zip
unzip master.zip
sudo cp -r ath10k-firmware-master/QCA9377 /lib/firmware/ath10k/
sudo mv /lib/firmware/ath10k/QCA9377/hw1.0/firmware-5.bin_WLAN.TF.1.0-00267-1 /lib/firmware/ath10k/QCA9377/hw1.0/firmware-5.bin

Reboot and your wireless should be working.

2
  • this didn't work for me
    – Suraj
    Jul 26, 2016 at 16:06
  • @Suraj Please start your own new question and we'll be happy to help you.
    – chili555
    Jul 26, 2016 at 18:07

Not the answer you're looking for? Browse other questions tagged or ask your own question.