My work computer sits behind a proxy (I know thats where the problem lies.) I was running 11.4 and using ssh to establish a socks proxy to my server at home. I can still connect to that server from other computers (Windows +putty) but when I try to connect to it from my Ubuntu box i get a connection reset by peer.

Also: Proxy requires authentication. My proxy settings are working for http. I tried to use dconf as well.

Thanks for any help!

  • This question appears to be abandoned and unanswered, could you perhaps add more detail to your question? If this question no longer applies then you can either delete it or answer it yourself if you've solved the problem. Thanks! – coversnail Apr 4 '12 at 16:30

Looks like you need corkscrew.

  1. Install corkscrew by sudo apt-get install corkscrew
  2. Create file ~/.corkscrew-auth
  3. Insert username:password into the file.
  4. Add following to you ssh config or command: ProxyCommand corkscrew 8080 %h %p ~/.corkscrew-auth Where is the IP of the proxy and 8080 is the port of the proxy.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.