I have just started with Ubuntu SDK.

My first small app is a sound recorder. I got the app to work in Desktop Mode.

When I switch to Ubuntu SDK for arm64 (gcc ubuntu-sdk 15.04-vivid) then the IDE reports the following error.

:-1: error: securityolicy_groups_safe:Audio1:debug: (REJECT) reserved policy group 'debug': not for production use.

Screenshot 1

Screenshot 2

Ubuntu SDK/IDE on Ubuntu 15.10 was a very traumatic and bad experience.

I already tried the IDE (Ubuntu SDK) on Ubuntu 15.10, but I got a lot of errors. Almost nothing worked for me there! Also the QAudioRecorder class outputted only WAV files even I carefully defined the parameters for MP3 or Vorbis. I purged and reinstalled Ubuntu SDK and apt-getted all possible qtdeclarative5-* packages without success. It was horrible! No one should meet such a buggy system!

Now I am running Ubuntu 16.04 (test) and the recording class works right here. It produces OGG Vorbis and other file formats correctly, from various devices.

I get the same policy error when deploying the app to my BQ Aquaris phone. It is Ubuntu Device (GCC armhf-ubuntu-sdk-15.04-vivid).

  • Please ask 2 questions seperately.
    – Star OS
    Dec 30, 2015 at 8:50


You must log in to answer this question.

Browse other questions tagged .