1

Im running Ubuntu 15.04 on an SSD which is low on space so I decided to download my Steam games onto a seporate HDD which has only Steam games. I set the partition of that HDD to autostart in Disk Utility, and ever since I rebooted, GUI would not appear and I would only have a text console. After logging into the console, it tells me:

/usr/lib/update-notifier/update-motd-updates-available: 39: /usr/lib/update-notifier/update-motd-updates-available/: cannot create /var/lib/update-notifier/updates-available: Read-only file system

/usr/lib/update-notifier/update-motd-fsck-at-reboot: 33 /usr/lib/update-notifier/update-motd-fsck-at-reboot: cannot create /var/lib/update-notifier/fsck-at-reboot: Read-only file system

These 2 errors seem to be related to a drive being mounted as Read-only, however the drive that I applied the mount option to is not in any way a system drive, and has only Steam games on it.

1 Answer 1

2

After hours of studying the boot process, I had to recreate the fstab file. First of all, I logged into the console as root and entered the command

mount -o rw,remount /

This temporarily restored the GUI allowing me to do further work. Then I opened a terminal, and ran

sudo nano /etc/fstab

and created this line:

/dev/sda1 / ext4 defaults 1 1

In each case, replace the "/dev/sda1" with the drive and partition of the device Linux boots from, replace the "/" with whatever the mount point is, and finally replace the "ext4" with the filesystem type.

1
  • 1
    Have an upvote my good man. Thanks for the solution.
    – Caustic
    Commented Jul 20, 2017 at 8:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .