3

I have installed the latest Mono Develop from the project site on Ubuntu 15.10. When I start it, I get the following errors.

Could not save solution: /usr/lib/monodevelop/bin/MonoDevelop.sln.
Access to the path /usr/lib/monodevelop/bin/MonoDevelop.sln is denied.

Load operation failed. 
Access to the path /usr/lib/monodevelop/bin/MonoDevelop.sln is denied.

How can I fix the errors?

f: /usr/lib/monodevelop/bin/MonoDevelop.sln
Drwxr-xr-x root root /
drwxr-xr-x root root usr
drwxr-xr-x root root lib
drwxr-xr-x root root monodevelop
drwxr-xr-x root root bin
                     MonoDevelop.sln - No such file or directory

Steps

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
echo "deb http://download.mono-project.com/repo/debian wheezy main" | sudo tee /etc/apt/sources.list.d/mono-xamarin.list
sudo apt-get update

sudo apt-get install mono-devel mono-complete monodevelop
  • I have added the output. – Pavel Dec 29 '15 at 19:21
  • From what I understand, a solution is user-created stuff. Why are you saving your creations in a system folder? – muru Dec 29 '15 at 19:23
  • I have just installed it, and I have not created this solution. – Pavel Dec 29 '15 at 19:24
  • Hmm. Also add the steps you took for installation. – muru Dec 29 '15 at 19:25
  • I have added the steps. – Pavel Dec 29 '15 at 19:29
4

I had the same issue. It turned out to be an odd entry in the monodevelop.desktop file. I have no idea how it happened, but here's how I fixed it:

  • Open alacarte (you might need to install with sudo apt-get install alacarte)
  • Find the MonoDevelop menu entry (I found it under Other, not Programming - YMMV) and open it
  • Change the command from monodevelop /usr/lib/monodevelop/bin/MonoDevelop.exe to monodevelop %F

It worked fine after that. I don't know how the command gets changed, but that's why your MonoDevelop installation things it's supposed to be opening that solution.

In my case, after I installed monodevelop I started it from the command line, right-clicked the icon in the launcher, and chose "Lock to Launcher". Since that seems like a pretty standard practice, I'm not sure how I (and you as well?) managed to end up with the same issue.

I checked both the main desktop file at https://github.com/mono/monodevelop/blob/master/main/monodevelop.desktop and the linux packaging desktop file at https://github.com/mono/linux-packaging-monodevelop/blob/master/monodevelop.desktop and they look correct to me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.