ADB in Android Studio (Ubuntu) ERROR : Unable to detect adb version, adb output: /home/hamid/Android/Sdk/platform-tools/adb: 1: /home/hamid/Android/Sdk/platform-tools/adb: Syntax error: ")" unexpected

  • Any one can help plz – Hamid Mustafa Dec 29 '15 at 16:33
  • 1
    When does this error occur? What did you do? How did you install it? What have you tried to fix it? – Trevor Clarke Dec 29 '15 at 23:26
  • i have same issue on windows 7 x64 .. i also installed genymotion. but none of emulators showing in target deployment dialogue. any idea for windows ? – Ubaid Mar 19 '19 at 22:30

Ubuntu 14.04.3 LTS

Got same error after update Android Studio and then Android SDK.

[SOLUTION : Downgrade /platform-tools folder]

  1. Download this arch. : https://dl-ssl.google.com/android/repository/platform-tools_r23.0.1-linux.zip
  2. Go to your Android SDK folder
  3. Remove old /platform-tools
  4. Insert downloaded from link above

Hope this help you.


Forgot specify that Ubuntu is 32 bit

  • Thanks buddy, it gone like flash! Thank you so much ..!! I solved my problem – Hamid Mustafa Dec 30 '15 at 4:36
  • This solved my problem too, on Linux Mint 17.1 32-bit – cctan Dec 31 '15 at 17:05
  • Thanks Elia, this worked on my 32bit Ubuntu 15.10, however when Android Studio updated the component it reverted to the 64bit version so no more updating of this component for me!. – Ian S Williams Feb 27 '16 at 4:08
  • 2
    Android Studio wanted an update which put the same bug back in. To fix, instead of replacing entire /platform-tools, instead, I just extracted adb by itself and that worked! – jim Sep 9 '16 at 19:49
  • Excellent advice. Also solves the problem on Ubuntu 16.04 on a 32-bit machine. – SANBI samples Nov 20 '16 at 11:06

This happened only for 32 bits linux platform.

The Android SDK Platform-tools Rev. 23.1.0 doesn't support 32 bits.

Some explanations are given (and asked) here :





Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.