18

I have 11.10 running on a system76 laptop. without the proprietary driver i was able to set up a second monitor (samsung 19") with extended display.

when i activate the proprietary driver, the only display setting that works is "mirror". when i pick to extend the display at the proper resolution (1280:1084, samsung) (1600:900, laptop) for each screen I get the following:

required virtual size does not fit available size: requested=(2880, 1024), minimum=(320, 200), maximum=(1600, 1600).

when i try to execute the resolutions that are set at default, after unchecking the "mirror screens" button (1152:864, samsung) (1600:900, laptop) i get the following:

requested position/size for CRTC 148 is outside the allowed limit: position=(1152, 0), size=(1152, 864), maximum=(1600, 1600)

  • bogdan's answer here: link works to get the dual monitors working, but it reverts back to mirroring the screens at low resolution upon reboot. configuring the screens messes up my synergy setup (mouse controlled by the server only goes partway across the first screen) so configuring at each boot is not a good workaround for me. any suggestions? – kenneth dyson Oct 24 '11 at 14:02
  • ok, think i got it working now. used administrator version of amd catalyst control center. set up dual screen display, laptop (1) right - samsung (2) left. set each display to recommended resolution. clicked apply. monitors worked, but synergy messed up. logged out and back in. back to mirrored screens at low resolution. went to displays in the systems menu. unticked mirror screens, set resolutions of each monitor to recommended, and it set up nicely, but synergy messed up again. logged out and back in....low and behold dual monitors with proper resolution set and synergy working fine! – kenneth dyson Oct 24 '11 at 14:15
  • Same problem, last post in this topic ubuntuforums.org/showthread.php?t=1855750 solved my problem. – user30814 Oct 26 '11 at 21:37
12

Type in this command, to open the AMD Catalyst Control Center

gksudo amdcccle
  1. Go to Display manager > There you must see your monitors.
  2. Click on the Monitor you want to setup display on
  3. Go to Multiple Screen Tab
  4. Change the display mode to your choice
  5. Apply this and restart
  • 3
    Should be accepted as an answer! I never even knew this was installed by default. I'm on an iMac running Ubuntu 12.04 and saw the need when the generic "Displays" threw the error mentioned in the OP. I was connecting the iMac to an external Cinema Display. The Catalyst Control Center solved this. – TryTryAgain Mar 1 '13 at 1:38
  • On 14.04, for "Display manager" to show on the GUI, you need to first edit "Switchable graphics" > "Rendering and additional displays". But like at askubuntu.com/questions/385781/… , I can't make amdcccle change the settings :( – Ciro Santilli 新疆改造中心法轮功六四事件 Feb 10 '15 at 11:10
  • Is there an option where you don't have to restart? Seriously, this takes me back in the days where you had to restart your system in order for a newly attacked PS/2 mouse/keyboard to get detected. Not cool at all especially in 2017. – rbaleksandar Feb 2 '17 at 9:23
  • @rbaleksandar, Depends on the kernel I think. If the kernel is able to reload the driver and communicate with the device correctly without restarting. Sure, but if not then restart is necessary and recommended. – Starx Feb 9 '17 at 10:05
  • I gave up. It turns out that whenever I enable multiple displays (beside cloning the desktop) a total ****strom breaks loose. Flickering display, frozen UI etc. are just a small subset of all the problems that occur in a very inconsistent way. – rbaleksandar Feb 9 '17 at 10:45
6

Open a terminal and type:

gksudo gedit /etc/X11/xorg.conf

In the sub-section "display" add this code or modify if already exist:

virtual 2880 1024

Where 2880 and 1024 are the value returned by the error: required virtual size does not fit available size: requested=(2880, 1024), minimum=(320, 200), maximum=(1600, 1600).

Restart the computer.

Then you will be able to extend your desktop without issue.

  • This works. One additional thing that you need to do is restart the machine. – SB. May 1 '12 at 4:24
  • The Display subsection should be a child of the Screen section. See askubuntu.com/a/75546/81211 – z0r Aug 26 '13 at 1:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.