0

I installed ubuntu 15.10 on my desktop running on core i7 4930k, nvidia 780ti, 16gb ram, 120gb ssd.

Every time I try to boot to ubuntu, it takes around 4-5 minutes. I used dmesg to check log. It looks something like this:

enter image description here

This thing keeps happening for 5 minutes and then the login screen appears. I tried disconnecting/reconnecting all my usb devices (mouse, keyboard and headset) during this loading period and still it doesn't stop. Please help.

PS: I am very new to ubuntu.

UPDATE: I entered this on the terminal:

lspci |grep -i ehci

And nothing new shows up:

enter image description here

Entered this on the terminal:

lspci -v | grep -i hci

And got this:

enter image description here

  • Can you add the output of lspci |grep -i ehci in your post? – Tung Tran Dec 29 '15 at 6:38
  • @TungTran Thank you for your reply. I updated my post. – Agent47 Dec 30 '15 at 0:48
  • try lspci -v | grep -i hci – user3113723 Dec 30 '15 at 3:33
  • @TungTran Updated my post. – Agent47 Dec 30 '15 at 4:28
  • You can just paste text from the terminal in a <pre> tag, not screenshots. Also, output of lsusb -t could be useful. – user3113723 Dec 30 '15 at 4:52
0

xhci_hcd is the usb-3 driver for the chip that the usb devices plug into. The driver is interacting poorly either with the chip or one of the devices. Hopefully, one of the devices.

Try removing all usb devices, then booting. Don't plug them in until you get to the login screen. This will tell you if the problem is in the chip or the devices. If the chip, you could try:

  1. Upgrading to a newer kernel. Maybe a mainline kernel. Possibly whatever's wrong has been fixed. Mainline kernels are here: https://wiki.ubuntu.com/Kernel/MainlineBuilds

  2. Disable xHCI, if you can find a switch for that in your BIOS.

  3. Ask somebody who knows more.

  • Thanks for replying. As you said, I tried booting up after removing all usb devices but the same issue persists. I will try the other steps that you mentioned and let you know. Thanks, again. – Agent47 Dec 30 '15 at 4:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.