I installed Webmin on Ubuntu server. I am trying to access the webmin interface from another computer in my LAN. If I use w3m (a command line browser) on the host machine I can start up webmin just fine. The problem is that w3m is woefully inadequate for webmin's web interface. If I try and use a computer on the same network I can't access the webmin interface no matter what I do.

My laptop and my server are on the same network, connected to a common router. I opened up a port 10000 for my server and my laptop.

I used ufw allow 10000/tcp to enable port 10000 on the firewall.

I tried to edit the webmin configuration file:

nano /etc/webmin/miniserver.conf

changing the port to 10001 and it worked from localhost, not from another machine. I remembered to restart webmin service after having modified the configurations with service webmin restart.

Can anyone help me access webmin's configuration page from my local LAN or remotely?


I've just installed ubuntu server 18.4 with webmin installed too.

I was meet the same problem (i can access webmin from local but can't from LAN network). and I found out how to get it to work.

There's many guilds tell you to reconfig webmin to disable SSL but:

Just simply add "https://" before your server_ip. it will look like ""

At least, it worked for me.

Hope this help.


I had the same issue and changing ports won't work.
You must have setup Webmin with SSL to prevent information passed between your browser and the server in unencrypted form.

At this point you must already be familiar with SSL and to configure your webmin page with https from any local browser:


for testing purpose only:
As a temporary and unsecure access to your webmin page from your local LAN you could remove that SSL setting, if you edit:
$ nano /etc/webmin/miniserver.conf

and change ssl setting from 1 to 0


Restart webmin service and check that you can login to your webmin page.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.