0

I'm using Ubuntu 15.10, and I've mounted some NAS folders using /etc/fstab. My problem is, that after rebooting Linux, applications such as Crashplan and VirtualBox (shared folders) see all mounted folders as if they were empty. I have to manually enter each folder once using e.g. Nautilus to make files visible.

Options in fstab are: iocharset=utf8,sec=ntlm,user

How to make these folders be accessible automatically?

1

I found that the following instructions from here worked for me on Lubuntu 15.10

Unprotected network folder won't automount

I've had a situation where an unprotected network folder wouldn't automount during bootup, but after manually entering "sudo mount -a" was mounted correctly. I solved this by replacing the "guest" option by "username=guest,password=".

//servername/sharename /media/windowsshare smbfs username=guest,password=,uid=1000,iocharset=utf8,codepage=unicode,unicode 0 0

Mount password protected network folders

The quickest way to auto-mounting a password-protected share is to edit /etc/fstab (with root privileges), to add this line:

//servername/sharename /media/windowsshare cifs username=msusername,password=mspassword,iocharset=utf8,sec=ntlm 0 0

Additional to this I used the following option to assure auto mount works:

_netdev

//servername/sharename /media/cloud cifs _netdev,uid=1000,gid=1000,dir_mode=0700,file_mode=0600,nounix,forceuid,forcegid,credentials=/home/myuser/.smbcredentials,iocharset=utf8,sec=ntlm 0 0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.