5

I have Ubuntu 15.10 installed and when I first start my computer it gives me the really nice looking ubuntu lightdm login screen but anytime I lock the computer I get the really nasty looking gnome lock screen. How can I make it only use one or the other?

Things I have tried:

  • reinstalling GDM
  • sudo dpkg-reconfigure on gdm and lightdm

$ dm-tool lock seems to lock correctly but pressing super + L takes me back to the ugly gdm lock screen.

My current workaround has been to change the keyboard shortcut to use dm-tool lock but that isn't really sustainable.

Edit:

Someone in the comments has suggested to remove the package gdm but when I try to it wants to remove ubuntu-gnome-desktop and the list below. Clearly this isn't what I want to do.

account-plugin-aim account-plugin-google account-plugin-jabber account-plugin-salut account-plugin-yahoo acpi-support aisleriot
  app-install-data-partner apturl apturl-common argyll argyll-ref baobab bluez-cups brltty cheese dc dconf-editor deja-dup
  deja-dup-backend-cloudfiles deja-dup-backend-gvfs deja-dup-backend-s3 duplicity empathy empathy-common file-roller fonts-cantarell
  .....
  syslinux-legacy telepathy-gabble telepathy-idle telepathy-logger telepathy-salut toshset transmission-common transmission-gtk
  ttf-ancient-fonts-symbola ttf-indic-fonts-core ubuntu-sso-client unity-asset-pool uno-libs3 unoconv ure usb-creator-common
  usb-creator-gtk vino whoopsie x11-apps x11-session-utils xdg-user-dirs-gtk xdiagnose xinit xorg xsltproc yelp-tools zsync
  • Are you running wallch, the wallpaper change program? I'm not using 15.10, so this is just a suggestion of something to try. – andy256 Dec 31 '15 at 2:50
  • I am not running that. However the background changes fine – Jared Mackey Dec 31 '15 at 2:51
  • I'm suggesting to try it. Can't hurt. – andy256 Dec 31 '15 at 4:17
  • Why do you have GDM installed at all? You should have no trouble removing it (apt-get purge gdm3). – John Scott Jan 2 '16 at 0:35
  • Remove gdm, that's all. – A.B. Jan 2 '16 at 17:25
2
+25

Super + L is a shortcut set within Compiz window manager. What is being set in the settings goes into gsettings ( which is a framework for storring app settings, that's slightly different ) and then relays whatever shortcuts you set to gnome-settings-daemon or unity-settings-daemon. That means we have to alter Compiz settings first.

The steps I personally took were as following:

  1. Install compizconfig-settings-manager with sudo apt-get install compizconfig-settings-manager
  2. Open compizconfig-settings-manager with ccsm command form terminal or from dash's search

  3. Under Ubuntu Unity Plugin option find Key to lock screen option, click on the button describing the shortcut.

You will see the a small popup window. Unckeck the enabled option. enter image description here

At this point you can go to Settings -> Keyboard -> Shortcuts and set custom shortcuts with keybinding Super + L as dm-tool lock command.

Tested on Ubuntu 14.04 LTS, Trusty

Edit

Since OP is using Ubuntu Gnome and not Unity, I used my 15.10 Ubuntu Gnome virtual machine, and found that in a normal session there's no compiz processes running , however the Super+L appears to be hard codded within the gnome-shell itself.

What I've successfully achieved is the following : run the gsettings command bellow and in the Settings -> Keyboard -> Shortcuts -> Custom menu set custom shortcut CtrlAltL to dm-tool lock command.

  gsettings set org.gnome.desktop.lockdown disable-lock-screen true

After running the command and creating shortcut, instead of the usual builtin gnome lock screen , I was able to use lightdm. OP also confirmed this in our conversation in the chat , but wanted Super + L to be the actual accelerator, and with better speed of locking. At the moment I am unable to address these issues, and it seems the key combination OP wants is hard-coded, hence unchangeable, but i am not 100% certain .

  • I am not using Unity so there is no section Ubuntu Unity Plugin – Jared Mackey Jan 6 '16 at 2:31
  • @electrometro First of you probably should have included that into your question. Your statement that you're using Ubuntu is a little bit misleading. Ubuntu Gnome would make more sense. Second, it really shouldn't matter, because with Ubuntu Gnome is also supposed to be using compiz, and the Super+L shortcut should be hard coded into compiz, and calls appropriate dbus command. – Sergiy Kolodyazhnyy Jan 6 '16 at 3:55
  • My bad, I thought the gnome tag was enough. I installed Ubuntu server and then installed ubuntu-gnome-desktop package afterwards. – Jared Mackey Jan 6 '16 at 3:59
  • @electrometro I see. I've a virtual machine with the same package installed. I'll investigate some more, see what i can do. – Sergiy Kolodyazhnyy Jan 6 '16 at 4:08
  • In response to a comment earlier, I don't have gdm3 installed. Rather, I have just gdm. – Jared Mackey Jan 6 '16 at 4:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.