26

I have ran sqlite3 from terminal but have problem exiting it.

this is how i have ran it:

sqlite3 database.db

i have tried CTRL+C but it wont exit, i have tried ESC, close(), exit() and it doesn't let me go.

2
  • 1
    Pretty cool how they came up with a unique command for quitting, that no other program in the world uses. It's like a little puzzle in the middle of your work day! Jan 29 at 19:23
  • 1
    @AndrewKoster And people complain about vim lol. I came here after running .help in v3.34.1 then trying to run .quit and .quit() multiple times with no effect (despite it clearly saying .quit on the screen)... at least Ctrl + D worked. Making a copy of the same db and trying again, I couldn't even recreate it. But yeah, would have preferred :q or ZQ myself...
    – zpangwin
    Jun 29 at 13:47
45

Type .quit or use Ctrl+D.

Type .help to get a list of available commands.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.