I'm using an external Audient iD14 audio interface with a Windows 10 and Ubuntu 14.04 dual boot system. I mainly use Windows for FL Studio and the Adobe Creative Suite, but I like to mess around with Ubuntu from time to time, especially for programming. Everything works great except that for some reason, Ubuntu lists my audio interface as Analogue Surround 4.0 when it actually only plays in stereo. As a result, the audio plays louder in the right channel than the left channel. While I can get it to work by adjusting the balance with the slider, it still sounds a little off. It's not bad, but it just doesn't sound as good as it does on Windows. So is there any way to force Ubuntu to treat sound devices as stereo? I know the problem might be that there are no Audient device drivers for Linux, but I wanted to make sure before I just accept to live with slightly poorer audio quality.

up vote 1 down vote accepted

Ubuntu (Linux in general) is correct in assigning 4 outputs as there are 4 outputs on the iD14. As you and I both know, only one pair of outputs are physically accessible. Outputs 3&4 are primarily used to send alternate mixes to musicians and are only accessible via the Audient mixer and/or DAW. The iD14 is class compliant in as far as it is recognised and some audio can be heard. Unfortunately that is as far as it goes (currently) as there is no mixer available to ALSA or Pulse etc. If you open a terminal and run alsamixer, press F6 and select Audient iD14, it will report a broken pipe error. ALSA (or Pulseaudio) has no way of knowing how to allocate the outputs, so assumes all 4 detected outs are available, but also has no way of directing signal appropriately. It "MAY" be possible to create a new sink and assign it as stereo, but you may still get an imbalance in left and right, or worse, have left and right output on one channel only. Also, all the digital inputs and Scroll Control functions will not work.

  • Ah, okay. Bummer. Well, thanks for your help anyway! – Bill Mess Jan 1 '16 at 3:57

i find solution in linux mint and lubuntu,maybe will work in another linux... in software menager type alsa and install qashctl ,then in menu,sound and video find and open qashctl and on the right side -mixer device under hw: select audient id 14 and on the left side under mixer open speaker.. volume and turn up volume to the top -127db and both channel work same and sound is very good.

a little late, but I found a workaround. You can't make Ubuntu recognize it as a stereo device. What you can do is configure your pulse daemon to play stereo sources only in stereo, instead of "remixing" them into surround.

Put this in your /etc/pulse/daemon.conf:

enable-remixing = no

After that, simply run a:

pulseaudio --kill

Your pulse daemon will restart, and hopefully you hear smooth stereo sounds.

  • It didn't work. I tried "enable-remixing = no" and "enable-lfe-remixing = no", and I made sure that they weren't commented out. – Bill Mess Jul 10 '16 at 23:28

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.