0

I have used Ubuntu on my laptop for several years without problems. I now want to download it to my desktop. I followed all the steps, but when it starts to load I get "This kernel requires an x84-64 CPU, but only detected an i686 CPU." I have read all previous questions on this matter but nothing seems to help. I have tried using the 32 bit programme but it does the same. I use AMI bios v02.61 and I cannot see a virtualisation setting but I have been told that this is already enabled. I am running short of idea's and any help I can get will be appreciated. I loaded the 64 bit system but in reading another persons problem, he was advised to try the 32 bit and it worked. The version I downloaded is Ubuntu 14.04.3 desktop-i386 iso The desktop is an Intel (R) Pentium(R) 4 CPU 2,8 GHz 2GBz Ram.

6
  • 2
    What do you mean be "tried using the 32 bit programme" ? Perhaps pointing to the links of the ISO's you've tried will help here.
    – fossfreedom
    Dec 28 '15 at 8:59
  • What is your CPU and OS (assuming you're using virtual machine)? Dec 28 '15 at 11:35
  • Thank you fossfreedom. What download do you recommend to enable me to load ubuntu on to my desktop please? Dec 28 '15 at 11:39
  • Ok, maybe I am confused and have misled you. I have a CPU currently running XP. As I have been very happy with Ubuntu on my laptop, I want to load 14.04 and replace the XP program on the desktop. Dec 28 '15 at 11:50
  • I need you to say which ISO you have tried - e.g. any of these? releases.ubuntu.com/trusty hint - the 32bit ISO's are "i386" - 64bit ISO's are "amd64"
    – fossfreedom
    Dec 28 '15 at 15:56
0

There are two main arch types: x86_64 (64 bit) and x86 (32 bit). Well it appears that you're trying to install a 64bit version of Ubuntu on a computer with a non 64-bit capable CPU. Pretty sure the i386/32bit installers don't contain 64bit kernels so you must've dwnloaded the wrong version.

1
  • Thank you all. I am starting from scratch again following everyone's advice. I will get back soon and let you know if I come right. Dec 30 '15 at 6:41
0

I have solved my problem. The USB flash I was using showed up in the bios. I selected bios to boot from it. It seemed to boot and gave me all the start-up options. It would then freeze until I selected "Help" I would then get the message "This kernel requires an x84-64 CPU, but only detected an i686 CPU." I realised that the flash was not booting and burned a disk. This worked like a dream. So in short although the flash was seen in the bios it was not booting. Thank all of you for your help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.