1

I have Ubuntu installed on one of my laptops with the GUI disabled. I installed openssh-server and tried accessing it from PuTTY from my Windows machine and it was working all fine. Later I had to switch WiFi networks on both Windows and Ubuntu. Switching in Windows was easy but with Ubuntu it took me some time. Now I have both the systems connected to the same network over WiFi. Even the Internet is accessible from the Ubuntu machine using elinks but ssh is not connecting from the Windows machine. Tried reinstalling but no luck. Please help.

Even I am unable to ping the Linux machine from my Windows PC. I tried ifconfig -a and got IP address 192.168.0.107 for wlan0. This is visible in the below screenshot:

ifconfig -a output

I also have Apache on 80 and Tomcat on 8080, but neither is accessible from the LAN, only from within the same PC.

  • Please find the image URL here : i.stack.imgur.com/ZsEa3.jpg – Aryasindhu Sahu Dec 28 '15 at 5:37
  • You could try re-installing openssh-server with 'sudo apt-get purge openssh-server' and then 'sudo apt-get install openssh-server'. – Max Kulik Dec 28 '15 at 6:56
  • Have done that but no luck. I think there is another issue with permission and all. As apache is also not accessible from outside. I have also added the entries for ssh and 80(apache) in iptables. Can you suggest anything else Max Kulik? – Aryasindhu Sahu Dec 28 '15 at 7:16
  • You are trying to access the laptop from Putty on the same local network, correct? – Max Kulik Dec 28 '15 at 7:18
  • Yes on the same network. – Aryasindhu Sahu Dec 28 '15 at 9:32

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.