1

I have installed Ubuntu 15.10 on an MSI GE72 6QD and could not install a working video driver (except the xserver-xorg-video-nouveau with serious limitations).

When I start normally, the machine freezes as the video initialization breaks the keyboard and mouse on a hardware conflict.

If I start in recovery mode, as the startup procedure is in text mode, the machine starts properly, but the video driver does not support a second monitor, which is a deal breaker for my job.

  1. How can I make the machine boot directly in recovery mode. (btw. all boot settings are ignored as recovery mode has its own configuration ¿does that make sense?)

  2. How/when/where can I find a driver for the nvidia GTX 960M

Please, help

(What I have already done:)

sudo ubuntu-drivers devices == /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 == vendor : NVIDIA Corporation model : GM107M [GeForce GTX 960M] modalias : pci:v000010DEd0000139Bsv00001462sd0000115Bbc03sc02i00 driver : nvidia-352-updates - distro non-free driver : nvidia-352 - distro non-free recommended driver : xserver-xorg-video-nouveau - distro free builtin

== cpu-microcode.py == driver : intel-microcode - distro non-free

I have installed both nvidia-352 and nvidia-352-updates and neither works forcing me to recover the original driver with a root shell and recovery mode as both blocked my machine.

  • How did you reach your conclusions? Did you see any relevant errors? – wie5Ooma Dec 28 '15 at 1:50
1

Edit your boot option and pass "nouveau.blacklist=1 nomodeset" as kernel option. This would allow Ubuntu 15.10 to boot using the Intel graphics card.

You may then make this kernel argument permanent by editing /etc/default/grub, where you should change the line:-

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to

GRUB_CMDLINE_LINUX_DEFAULT="nouveau.blacklist=1 quiet splash nomodeset" 

Then run

sudo update-grub2

to make the change permanent. So far, none of the nvidia drivers are working in GE72 6QD. I have even tried using 361.XX drivers, while the latest stable version is 352.XX.

0

The following solution worked perfectly in my MSI GE72 6QD.

  1. Uninstall all nvidia drivers.
  2. Change GRUB_CMDLINE_LINUX_DEFAULT to:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.preliminary_hw_support=1 i915.enable_execlists=0 intel_pstate=disable i915.enable_rc6=0"
    
  3. Then run sudo update-grub2 to make the change permanent.

  4. Restart your laptop to witness the proper function of video screen, which is using the Intel GPU now.
  5. Now you can change the screen brightness using the Fn+Brightness key. Previous to this change, my screen brightness remained the same always.

  6. Install the latest nvidia driver using apt-get. In my case, I installed 361.18 and my Kernel was 4.2.0-27

  7. Restart now and see nvidia driver in action. I had checked the functionality by running nvidia-settings.

Reference: https://gist.github.com/ngangat/02c8279e49783328de3a

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.