0

when i try to launch android studio bu terminal using the file studio.sh all went well and the program is on but i see these line

Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=350m; support was removed in 8.0
Error Loading DDMS Preferences

all it's ok or I have to do something?

0

Go to the directory where you have Android Studio. Then go to the bin/ subdirectory. Locate the following files, which contains Java Virtual Machine options:

  • studio.vmoptions
  • studio64.vmoptions

Open these files and locate line with MaxPerSize parameter. It should look as follows:

XX:MaxPermSize=256m

Remove this line in both files. I don't know if you are using 32-bit or 64-bit operating system, so you can update both files just in case.

I'm not sure if it will solve your problem, but I would try it in such situation. In my case, with this option and Java 8, I just get the warning, but Android Studio starts anyway. After removing this parameter, Android Studio still starts, but without warning. I'm using Ubuntu 14.04 LTS.

EDIT:

There is another solution for this problem described here: https://stackoverflow.com/a/27913562/1150795.

Go to File > Other Settings > Default Project Structure > JDK location and check the path.

In case of Ubuntu Linux, we can set /usr/lib/jvm/java-7-oracle as default JDK if we are using Oracle JVM. JDK 7 is the safest option for Android.

  • can u tell me why I had this problem? – Giovanni Giampaolo Dec 30 '15 at 10:00
  • you had it in your error log: support was removed in 8.0. JDK8 made some changes for which Android Studio with Gradle was not prepared :-D – piotrek1543 Dec 30 '15 at 10:50

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.