0

Wifi connection was weak and would disconnect often so I followed the steps at link1. The issue was not solved so I tried link2. Unfortunately this time wifi does not work at all..Ethernet works just fine. All I know is linux kernel got updated after I tried link2 from 3.19.0-25.26 to 3.19.0-42.48

Wireless info script output is here

Need help to get the network card working. Thanks in advance!

Edit:

modinfo rtl8723be

filename:       /lib/modules/3.19.0-42-
generic/updates/dkms/rtl8723be.ko
firmware:       rtlwifi/rtl8723befw.bin
description:    Realtek 8723BE 802.11n PCI wireless
license:        GPL
author:         Realtek WlanFAE <wlanfae@realtek.com>
author:         PageHe  <page_he@realsil.com.cn>
srcversion:     1A35907BCCEF84FE28F988D
alias:          pci:v000010ECd0000B723sv*sd*bc*sc*i*
depends:        rtlwifi,rtl_pci,btcoexist,mac80211
vermagic:       3.19.0-42-generic SMP mod_unload modversions 
parm:           swlps:bool
parm:           swenc:using hardware crypto (default 0 [hardware])
 (bool)
parm:           ips:using no link power save (default 1 is open)
 (bool)
parm:           fwlps:using linked fw control power save (default 1 is open)
 (bool)
parm:           msi:Set to 1 to use MSI interrupts mode (default 0)
 (bool)
parm:           debug:Set debug level (0-5) (default 0) (int)
parm:           disable_watchdog:Set to 1 to disable the watchdog (default 0)
 (bool)

sudo modprobe -r rtlwifi && sudo modprobe rtl8723be || sudo dmesg | tail -n 20

modprobe: FATAL: Module rtlwifi is in use.
[ 8016.688908] vgaarb: this pci device is not a vga device
[ 8042.309402] atkbd serio0: Unknown key pressed (translated set 2, code 0xd8 on isa0060/serio0).
[ 8042.309407] atkbd serio0: Use 'setkeycodes e058 <keycode>' to make it known.
[ 8042.317523] atkbd serio0: Unknown key released (translated set 2, code 0xd8 on isa0060/serio0).
[ 8042.317531] atkbd serio0: Use 'setkeycodes e058 <keycode>' to make it known.
[ 8042.594891] i915_bpo 0000:00:02.0: BAR 6: [??? 0x00000000 flags 0x2] has bogus alignment
[ 8042.595060] i915_bpo 0000:00:02.0: BAR 6: [??? 0x00000000 flags 0x2] has bogus alignment
[ 8042.601010] [drm:gen8_irq_handler [i915_bpo]] *ERROR* The master control interrupt lied (SDE)!
[ 8042.706421] vgaarb: this pci device is not a vga device
[13220.548635] atkbd serio0: Unknown key pressed (translated set 2, code 0xd7 on isa0060/serio0).
[13220.548645] atkbd serio0: Use 'setkeycodes e057 <keycode>' to make it known.
[13220.556650] atkbd serio0: Unknown key released (translated set 2, code 0xd7 on isa0060/serio0).
[13220.556663] atkbd serio0: Use 'setkeycodes e057 <keycode>' to make it known.
[13220.608543] i915_bpo 0000:00:02.0: BAR 6: [??? 0x00000000 flags 0x2] has bogus alignment
[13220.608666] i915_bpo 0000:00:02.0: BAR 6: [??? 0x00000000 flags 0x2] has bogus alignment
[13220.779499] vgaarb: this pci device is not a vga device
[13531.306668] vgaarb: this pci device is not a vga device
[13688.660608] vgaarb: this pci device is not a vga device
[14147.339430] vgaarb: this pci device is not a vga device
[14531.406230] vgaarb: this pci device is not a vga device

uname -r

3.19.0-42-generic

sudo lshw -C network

*-network UNCLAIMED     
   description: Network controller
   product: RTL8723BE PCIe Wireless Network Adapter
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: pci@0000:08:00.0
   version: 00
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress cap_list
   configuration: latency=0
   resources: ioport:5000(size=256) memory:c6100000-c6103fff
  *-network
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:09:00.0
       logical name: eth0
       version: 0a
       serial: 3c:a8:2a:bc:2a:8e
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8107e-2_0.0.2 02/26/15 ip=192.168.5.2 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:49 ioport:4000(size=256) memory:c6004000-c6004fff memory:c6000000-c6003fff

Edit 2:

sudo initctl stop network-manager

sudo modprobe -r rtlwifi && sudo modprobe rtl8723be || sudo dmesg | tail -n 20

zaman@zaman-Notebook:~$ sudo initctl stop network-manager
[sudo] password for zaman: 
network-manager stop/waiting
zaman@zaman-Notebook:~$ sudo modprobe -r rtlwifi && sudo modprobe rtl8723be || sudo dmesg | tail -n 20
modprobe: FATAL: Module rtlwifi is in use.
[ 2053.932069] atkbd serio0: Use 'setkeycodes e02b <keycode>' to make it known.
[ 2053.985389] atkbd serio0: Unknown key released (translated set 2, code 0xab on isa0060/serio0).
[ 2053.985393] atkbd serio0: Use 'setkeycodes e02b <keycode>' to make it known.
[ 2054.084680] atkbd serio0: Unknown key pressed (translated set 2, code 0xab on isa0060/serio0).
[ 2054.084685] atkbd serio0: Use 'setkeycodes e02b <keycode>' to make it known.
[ 2054.132757] atkbd serio0: Unknown key released (translated set 2, code 0xab on isa0060/serio0).
[ 2054.132762] atkbd serio0: Use 'setkeycodes e02b <keycode>' to make it known.
[ 2054.230363] atkbd serio0: Unknown key pressed (translated set 2, code 0xab on isa0060/serio0).
[ 2054.230367] atkbd serio0: Use 'setkeycodes e02b <keycode>' to make it known.
[ 2054.272300] atkbd serio0: Unknown key released (translated set 2, code 0xab on isa0060/serio0).
[ 2054.272304] atkbd serio0: Use 'setkeycodes e02b <keycode>' to make it known.
[ 2054.538206] atkbd serio0: Unknown key pressed (translated set 2, code 0xab on isa0060/serio0).
[ 2054.538210] atkbd serio0: Use 'setkeycodes e02b <keycode>' to make it known.
[ 2054.613514] atkbd serio0: Unknown key released (translated set 2, code 0xab on isa0060/serio0).
[ 2054.613518] atkbd serio0: Use 'setkeycodes e02b <keycode>' to make it known.
[ 2054.890514] atkbd serio0: Unknown key pressed (translated set 2, code 0xab on isa0060/serio0).
[ 2054.890517] atkbd serio0: Use 'setkeycodes e02b <keycode>' to make it known.
[ 2054.994063] atkbd serio0: Unknown key released (translated set 2, code 0xab on isa0060/serio0).
[ 2054.994068] atkbd serio0: Use 'setkeycodes e02b <keycode>' to make it known.
[ 2171.306785] systemd-hostnamed[3531]: Warning: nss-myhostname is not installed. Changing the local hostname might make it unresolveable. Please install nss-myhostname!

lsmod |grep rtl

zaman@zaman-Notebook:~$ lsmod |grep rtl
rtl8723be              90112  0 
btcoexist              53248  1 rtl8723be
rtl8723_common         24576  1 rtl8723be
rtl_pci                28672  1 rtl8723be
rtlwifi                73728  2 rtl_pci,rtl8723be
mac80211              708608  3 rtl_pci,rtlwifi,rtl8723be
cfg80211              524288  2 mac80211,rtlwifi

zaman@zaman-Notebook:~$ modprobe -r rtlwifi
modprobe: FATAL: Module rtlwifi is in use.
zaman@zaman-Notebook:~$ ifconfig wlan0 down
SIOCSIFFLAGS: Operation not permitted

Update:

I booted to my earlier kernel version 3.19.0-25 instead of the latest 3.19.0-42 and the wifi seems to be working! It is unstable though!

Questions:

  1. I want to remove the latest kernel where I had the driver issues since I no longer need it, how do I do that?

  2. The wifi is unstable and keeps disconnecting as I move away from the router, any fix for this?

  • The kernel log (lines 327f of pastebin.ubuntu.com/14230656) points to a kernel module mismatching your kernel version. Which driver source (from which answer of the linked questions) were you using while running the Wifi diagnostics and did you (re-)compile the driver for the current kernel? – David Foerster Dec 27 '15 at 15:21
  • @DavidFoerster : I followed the links in the same order, the wireless script was run after the steps in [link] (askubuntu.com/questions/645220/…) I did not compile the driver for the current kernel as the last step said "reboot" – silent_monk Dec 27 '15 at 16:45
  • What's the output of modinfo rtl8723be? It also looks like that module isn't loaded in favour of rtlwifi. What happens, when you run sudo modprobe -r rtlwifi && sudo modprobe rtl8723be || sudo dmesg | tail -n 20? – David Foerster Dec 28 '15 at 13:13
  • Attaching the results in images as I am not sure what happened there..img1 and img2 . Does it mean anything to you? – silent_monk Dec 30 '15 at 15:15
  • 1
    Possible duplicate of Realtek 8723BE Wifi problem – Pilot6 Jul 28 '16 at 12:02
0

Hello,

I have the same wireless card, and I had problems with wifi after updates as well.

Establish a temporary internet connection (with ethernet cable), open up a terminal and try these commands.

sudo apt-get install build-essential git
git clone https://github.com/lwfinger/rtlwifi_new/
cd rtlwifi_new
make
sudo make install

After doing this, reboot and your wifi should be working.

When this does not fix your problem, try this:

Go to BIOS and disable secure boot!

Maybe your system is not allowing your wireless card.

Hope I helped! -orion-

  • Thank you. It solves my problem even after these years. What I don't understand is that the wifi connection drops every few weeks and then I have to repeat these steps all over again to ensure connectivity. Anyone else have this issue or was it a one time fix? – silent_monk Oct 4 '18 at 3:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.