0

This question already has an answer here:

I am a new user on Ubuntu. Currently, i am running Ubuntu 14.04 32-bit on my PC. Lately, I've been facing problem in installing any software or package using terminal. I've also tried the following codes to fix this but it failed...

  sudo apt-get autoclean
  sudo apt-get clean

So this is how it looks like....

sajal@sajal-945GCMX-S2:~$ sudo apt-get install aircrack-ng
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 aircrack-ng : Depends: libc6 (>= 2.15) but it is not going to be installed
               Depends: libgcrypt11 (>= 1.4.5) but it is not going to be installed
               Depends: libsqlite3-0 (>= 3.5.9) but it is not going to be installed
               Depends: zlib1g (>= 1:1.1.4) but it is not going to be installed
               Depends: wireless-tools but it is not going to be installed
               Depends: iw but it is not going to be installed
               Recommends: wget but it is not going to be installed
 minitube : Depends: libc6 (>= 2.3.6-6~) but it is not going to be installed
            Depends: libgcc1 (>= 1:4.1.1) but it is not going to be installed
            Depends: libphonon4 (>= 4:4.2.0) but it is not going to be installed
            Depends: libqt4-dbus (>= 4:4.5.3) but it is not going to be installed
            Depends: libqt4-network (>= 4:4.5.3) but it is not going to be installed
            Depends: libqt4-script (>= 4:4.5.3) but it is not going to be installed
            Depends: libqt4-sql (>= 4:4.5.3) but it is not going to be installed
            Depends: libqtcore4 (>= 4:4.8.0) but it is not going to be installed
            Depends: libqtgui4 (>= 4:4.8.0) but it is not going to be installed
            Depends: libstdc++6 (>= 4.2.1) but it is not going to be installed
            Depends: phonon but it is not going to be installed
            Depends: phonon-backend-gstreamer but it is not going to be installed or
                     phonon-backend
            Depends: dbus-x11 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution)

Please help me with this........

marked as duplicate by Mitch Dec 27 '15 at 12:41

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Do this sudo apt-get update && sudo apt-get upgrade – Raphael Dec 27 '15 at 12:12
  • Did you do this - sudo apt-get -f install ? – Raphael Dec 27 '15 at 12:13
0

Make sure that you have the universe repository enabled.

enter image description here This answer has been discussed in detail here.

Not the answer you're looking for? Browse other questions tagged or ask your own question.