4

Ubuntu 15.10 (tried other versions as well using both installed and live CDs) on an Acer Aspire E5-574 . When you try to suspend the computer using either the power button, fn-f4 or pm-suspend the computer immediately powers off. Nothing useful in the pm-suspend.log which is included below:

Running hook /usr/lib/pm-utils/sleep.d/00logging suspend suspend:
Linux aspire 3.19.0-32-generic #37~14.04.1-Ubuntu SMP Thu Oct 22 09:41:40 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
Module                  Size  Used by
ctr                    16384  2 
ccm                    20480  2 
rfcomm                 69632  8 
bnep                   20480  2 
arc4                   16384  2 
uvcvideo               90112  0 
videobuf2_vmalloc      16384  1 uvcvideo
ath10k_pci             45056  0 
videobuf2_memops       16384  1 videobuf2_vmalloc
ath10k_core           290816  1 ath10k_pci
videobuf2_core         53248  1 uvcvideo
ath                    32768  1 ath10k_core
v4l2_common            16384  1 videobuf2_core
rtsx_usb_sdmmc         28672  0 
videodev              159744  3 uvcvideo,v4l2_common,videobuf2_core
rtsx_usb_ms            20480  0 
memstick               20480  1 rtsx_usb_ms
rtsx_usb               24576  2 rtsx_usb_sdmmc,rtsx_usb_ms
media                  24576  2 uvcvideo,videodev
binfmt_misc            20480  1 
acer_wmi               20480  0 
sparse_keymap          16384  1 acer_wmi
mac80211              643072  1 ath10k_core
cfg80211              532480  3 ath,mac80211,ath10k_core
x86_pkg_temp_thermal    16384  0 
compat                 28672  4 cfg80211,mac80211,ath10k_pci,ath10k_core
coretemp               16384  0 
snd_hda_codec_hdmi     53248  1 
snd_hda_codec_realtek    81920  1 
snd_hda_codec_generic    69632  1 snd_hda_codec_realtek
kvm_intel             151552  0 
kvm                   479232  1 kvm_intel
snd_hda_intel          36864  6 snd_hda_codec_hdmi
snd_hda_controller     32768  1 snd_hda_intel
snd_hda_codec         143360  5 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_intel,snd_hda_controller
snd_hwdep              20480  1 snd_hda_codec
crct10dif_pclmul       16384  0 
btusb                  40960  0 
i915_bpo             1138688  4 
bluetooth             491520  22 bnep,btusb,rfcomm
snd_pcm               106496  5 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_controller
crc32_pclmul           16384  0 
snd_seq_midi           16384  0 
snd_seq_midi_event     16384  1 snd_seq_midi
snd_rawmidi            32768  1 snd_seq_midi
snd_seq                65536  2 snd_seq_midi_event,snd_seq_midi
intel_ips              20480  1 i915_bpo
snd_seq_device         16384  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              32768  2 snd_pcm,snd_seq
ghash_clmulni_intel    16384  0 
aesni_intel           172032  5 
drm_kms_helper        126976  1 i915_bpo
aes_x86_64             20480  1 aesni_intel
dm_multipath           24576  0 
lrw                    16384  1 aesni_intel
scsi_dh                16384  1 dm_multipath
drm                   344064  5 i915_bpo,drm_kms_helper
gf128mul               16384  1 lrw
snd                    86016  20 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec_generic,snd_hda_codec,snd_hda_in
tel,snd_seq_device
joydev                 20480  0 
glue_helper            16384  1 aesni_intel
serio_raw              16384  0 
ablk_helper            16384  1 aesni_intel
i2c_algo_bit           16384  1 i915_bpo
cryptd                 20480  3 ghash_clmulni_intel,aesni_intel,ablk_helper
soundcore              16384  2 snd,snd_hda_codec
shpchp                 40960  0 
i2c_hid                20480  0 
acpi_pad               20480  0 
dell_smo8800           16384  0 
nls_iso8859_1          16384  2 
mac_hid                16384  0 
parport_pc             32768  0 
ppdev                  20480  0 
lp                     20480  0 
parport                45056  3 lp,ppdev,parport_pc
dm_mirror              24576  0 
dm_region_hash         24576  1 dm_mirror
dm_log                 20480  2 dm_region_hash,dm_mirror
uas                    24576  0 
usb_storage            69632  2 uas
hid_generic            16384  0 
usbhid                 53248  0 
hid                   110592  3 i2c_hid,hid_generic,usbhid
psmouse               114688  0 
r8169                  81920  0 
mii                    16384  1 r8169
ahci                   36864  3 
libahci                32768  1 ahci
wmi                    20480  1 acer_wmi
video                  20480  2 i915_bpo,acer_wmi
             total       used       free     shared    buffers     cached
Mem:       8039304    1208708    6830596     360888      50048     738180
-/+ buffers/cache:     420480    7618824
Swap:      8251388          0    8251388
/usr/lib/pm-utils/sleep.d/00logging suspend suspend: success.

Running hook /usr/lib/pm-utils/sleep.d/00powersave suspend suspend:
/usr/lib/pm-utils/sleep.d/00powersave suspend suspend: success.

Running hook /etc/pm/sleep.d/10_grub-common suspend suspend:
/etc/pm/sleep.d/10_grub-common suspend suspend: success.

Running hook /etc/pm/sleep.d/10_unattended-upgrades-hibernate suspend suspend:
/etc/pm/sleep.d/10_unattended-upgrades-hibernate suspend suspend: success.

Running hook /usr/lib/pm-utils/sleep.d/50unload_alx suspend suspend:
/usr/lib/pm-utils/sleep.d/50unload_alx suspend suspend: success.

Running hook /usr/lib/pm-utils/sleep.d/60_wpa_supplicant suspend suspend:
Selected interface 'wlan0'
OK
/usr/lib/pm-utils/sleep.d/60_wpa_supplicant suspend suspend: success.

Running hook /usr/lib/pm-utils/sleep.d/75modules suspend suspend:
/usr/lib/pm-utils/sleep.d/75modules suspend suspend: not applicable.

Running hook /usr/lib/pm-utils/sleep.d/90clock suspend suspend:
/usr/lib/pm-utils/sleep.d/90clock suspend suspend: not applicable.

Running hook /usr/lib/pm-utils/sleep.d/94cpufreq suspend suspend:
/usr/lib/pm-utils/sleep.d/94cpufreq suspend suspend: success.

Running hook /usr/lib/pm-utils/sleep.d/95anacron suspend suspend:
stop: Unknown instance: 
/usr/lib/pm-utils/sleep.d/95anacron suspend suspend: success.

Running hook /usr/lib/pm-utils/sleep.d/95hdparm-apm suspend suspend:
/usr/lib/pm-utils/sleep.d/95hdparm-apm suspend suspend: not applicable.

Running hook /usr/lib/pm-utils/sleep.d/95led suspend suspend:
/usr/lib/pm-utils/sleep.d/95led suspend suspend: not applicable.

Running hook /usr/lib/pm-utils/sleep.d/98video-quirk-db-handler suspend suspend:
Kernel modesetting video driver detected, not using quirks.
/usr/lib/pm-utils/sleep.d/98video-quirk-db-handler suspend suspend: success.

Running hook /usr/lib/pm-utils/sleep.d/99video suspend suspend:
kernel.acpi_video_flags = 0
/usr/lib/pm-utils/sleep.d/99video suspend suspend: success.

Running hook /etc/pm/sleep.d/novatel_3g_suspend suspend suspend:
/etc/pm/sleep.d/novatel_3g_suspend suspend suspend: success.

Sun Dec 27 12:26:35 IST 2015: performing suspend

As you can see, it gets cut off abruptly at the point at witch the machines powers off.

Has anyone seen this before? Is there a remedy?

4
+50

If you're using grub you could try modifying the GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub. (Make a backup first! $ sudo cp /etc/default/grub /etc/default/grub.orig )

  1. Use your favorite text editor to open /etc/default/grub

    $ sudo vi /etc/default/grub
    or
    $ gksu gedit /etc/default/grub
    
  2. Find the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" and add to it (Note: you may have other things here like acpi_backlight=vendor and this okay just add this at the end)

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_sleep=nonvs"
    
  3. Update grub, reboot and try it out.

    $ sudo update-grub
    $ sudo reboot
    

    If you're still having trouble they could be related to graphics driver issues like my older Acer was (though I don't have this problem on 15.10) so you can try following the same procedure but also add nomodeset to /etc/default/grub:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_sleep=nonvs nomodeset"
    

Hopefully one of those works for you. I don't have a good source for the nonvs line but basically NVS is nonvolatile storage saving it created problems so kernel developers in the 2.x days implemented the ability to disable saving it. If this works for you it should have minimal impact (and if it doesn't you can choose to remove it before/after trying nomodeset.

And a note about nomodeset, it forces the system to use the bios video drivers which can correct problems like this (I've found personally Acer's are notorious for video driver problems). I've heard that adding nomodeset can cause side effects like not detecting external displays but I never noticed anything like that. More info on nomodeset: What does `nomodeset` do

Updated: I came across a few Acer specific problems on various theads pointing at i8042 as the problem but they were mostly on older machines/kernels. So before trying these below I'd recommend trying to figure out specifically is going on. Try checking /var/log/syslog

grep -ni /var/log/syslog -e "Err"

I like using grep -n (-i is ignore case and -e is the expression to search for) as it gives me line numbers so I can then go to the file and explore around in that area to see if more info is revealed. If that isn't helpful you could try to look at all the logs for errors:

grep -rni /var/log -e "Err"

And finally if all else fails you try the fixes I found for older Acer models and older kernels:

You could try setting the i8042.reset kernel parameter and testing (don't reboot before trying to suspend)

# sysctl -e -w i8042.reset

Then if it works you can make it permanent by editing the /etc/default/grub and locating GRUB_CMDLINE_LINUX="" (note the difference here!):

GRUB_CMDLINE_LINUX="i8042.reset"

Sometimes i8042.nomux can also be the culprit on Acer Machines so you can try it out.

Source: https://wiki.archlinux.org/index.php/Pm-utils More info on kernel parameters: https://www.kernel.org/doc/Documentation/kernel-parameters.txt

9
  • A for effort. I had already tried acpi_sleep=nonvs without success but nomodeset hadn't been tried. It works partially. With nomodset the laptop's power LED changes color when suspend is invoked. So that's a big step forward however it is impossible to wake the computer up, has to do a complete power cycle to get it back. Also with nomodeset only one display is active at a time. – middlestump Jan 1 '16 at 16:48
  • Did checking out syslog reveal anything? – snorp Jan 2 '16 at 13:52
  • I'd also be curious if your pm-suspend log has changed with the new kernel parameters. And yeah nomodeset often comes with side effects that need work around which is annoying. I'd say this indicates its related to video card/drivers. Is this a card with proprietary drivers? Have you tried installing or removing those drivers? – snorp Jan 2 '16 at 13:59
  • One more thought on this, when you say impossible to wake up... does it not power on or does it power on with a black screen or something else? – snorp Jan 2 '16 at 14:14
  • @e4c5 you changed usernames on me? Ah yeah if its Intel graphics that probably isn't the issue. You see that being the cause more so with proprietary graphics. Do you see in syslog anything registered that the system tried to wake up? – snorp Jan 5 '16 at 1:27
3

At the end of the day. It turned out to be bug in the BIOS. You need to do a BIOS update. However acer only providers .EXE files as updates. It was made by downloading FreeDos 10MB image and following the instructions at Archlinux. Even though this system wasn't on archlinux, their guide is still valid.

It was touch and go for a moment because the laptop had a tendency to power off when changing from AC to Battery. So if I had suffered a power failure while the BIOS was updating the laptop probably would have been kaput.

2
  • Glad you got it figured out. @e4c5 have you tried this too? – snorp Jan 7 '16 at 14:43
  • Yes thanks @snorp I have upvoted your answer earlier. Freedos gave me a few scares (hitting tab for command completion (out of habit)) cause a total freeze. That made me wonder if Freedos is compatible with skylake hardware. But in the end took the plunge and I am glad I did. Thanks again – e4c5 Jan 7 '16 at 15:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.