72

How to change the screen resolution?

I tried with this command:

rdesktop <server_ip>

But the screen does not appear large.

1
  • FYI, using the -f option will use ALL the connected monitors...
    – user139995
    Mar 13, 2013 at 14:53

7 Answers 7

69

I like using this command:

rdesktop -g 90% servername

Which will set the size of the remote desktop to 90% of the size of your local screen, which works quite well regardless of resolution.

4
  • 9
    Problems if you have a dual-screen... Dec 1, 2013 at 13:43
  • Is there viable solutions from WindowsNT to Gnome that offer specifying graphical resolution? Apr 14, 2014 at 18:10
  • 3
    For dual screen: -g $(xrandr -q | awk '/Screen 0/ {print int($8/1.28) $9 int($10/1.2)}' | sed 's/,//g')
    – gavenkoa
    Dec 24, 2014 at 14:07
  • 1
    Sorry, old thread. But when I work on a multiple monitor workstation I like that the remote desktop only in on one screen. I modified gacenkoa awesome script to this: -g $(xrandr -q | awk '/ connected / {print $4;exit}' | awk -F "x" '{print int($1/1.05)"x"int($2/1.1)}') This will look for the first connected monitor and then make the window a little smaller than that screen.
    – RobL
    Mar 2, 2019 at 18:22
42

If you want to open the screen at a specific resolution, for example 1280×1024 resolution, add the -g flag:

rdesktop -g 1280x1024 <server_ip>
1
  • 2
    Somehow I can make it as wide as I want, but the height is very limited. Dec 1, 2013 at 14:53
15

This command gives you a full screen experience as well:

rdesktop -f
2
  • 3
    Doesn't work well with multiple displays: it spreads the window over all of them. Feb 3, 2016 at 16:37
  • 5
    Ctrl + Alt + Enter if you're wondering how to minimise / exit the remote session
    – The Coder
    Apr 26, 2017 at 7:17
12

I found the answer to my question.

  • -k de: set keyboard layout
  • -g 1500x1150: set resolution of the rdesktop window
  • -r disk:mydisk=/home/soma: share your home directory with the remote machine

The full command should be:

rdesktop 192.168.1.23 -k de -g 1500x1150 -r disk:mydisk=/home/soma 
8

I'd suggest that you consider a graphical tool such as Remmina (used to be called GRDC), which is available in the repositories.

sudo apt-get install remmina remmina-plugin-rdp remmina-plugin-vnc

It features easy to use drop downs and sliders for remote screen resolution, supporting multiple monitors and more.

It also supports VNC and SSH tunnelling, making it a one-stop-shop for all your most likely remote desktop connection needs. Finally, a handy gnome-panel applet makes connecting to your remote desktops a simple point and click experience.

Screenshots here : http://remmina.sourceforge.net/screenshots.shtml

4
  • 1
    remmina-gnome doesn't exist (at least in Oneiric), but this worked for me: sudo apt-get install remmina remmina-plugin-rdp remmina-plugin-vnc
    – Phil Hord
    Nov 8, 2011 at 18:16
  • Nice one - they must have updated the packages in Oneiric. Have updated my answer.
    – Scaine
    Nov 8, 2011 at 22:34
  • And upvoted you for the call out!
    – Scaine
    Nov 10, 2011 at 9:00
  • But remmina does not work properly with 3G. You have to connect 20 times until yo
    – user578237
    Aug 5, 2016 at 15:52
1

I had the problem on my Ubuntu 20.10 notebook that my screen has 1920x1080 but only 14 inch, so the dpi is higher on my notebook screen than on the monitor of the remote computer

I could adjust this by using -g parameter with the DPI option, that is specified via an @ sign.

rdesktop -g 100%@150 <remote_computer>

The 100% refer to my screen size and the higher the value after the 1

1
  • thanks (from 2021).
    – Lester
    Jun 3, 2021 at 16:54
-1

oldSkool:

I think Ctrl + Alt + KP+ also cycles through some available resolutions.

2
  • 1
    That's for the local display resolution. He's using rdesktop which used RDP to pull a display from a remote Windows system. It's the resolution of thew Windows system displayed on his workstation he wants to adjust.
    – dan_linder
    Nov 8, 2011 at 22:39
  • what's KP+ ? -- probably the Plus on the numeric KeyPad
    – knb
    May 6 at 8:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy