3

I have a Dell Inspiron i7559, which has an unfortunate combination of a NVidia GTX960M and an Intel 3165 AC card. All proprietary NVidia drivers only seem to work on the 3.x kernels, whereas the official iwlwifi firmware for this card is only available on kernel 4.1+: so currently I am on 3.19 because I need the GPU and I am using a USB wireless module.

So, I am wondering if there are any options for making the internal card usable in kernel 3.19. Ubuntu detects it as an Intel 3165 card. For more information:

$ lshw -C network
 *-network UNCLAIMED
   description: Network controller
   product: Intel Corporation
   vendor: Intel Corporation
   physical id: 0
   bus info: pci@0000:05:00.0
   version: 79
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress cap_list
   configuration: latency=0
   resources: memory:df200000-df201fff

$ lspci
05:00.0 Network controller: Intel Corporation Device 3165 (rev 79)

Thanks for your time!

3 Answers 3

5

With a working internet connection by ethernet, tethered or whatever means possible, open a terminal and do

sudo apt-get update
sudo apt-get install linux-headers-generic build-essential
wget https://www.kernel.org/pub/linux/kernel/projects/backports/2015/11/20/backports-20151120.tar.gz
tar -zxvf backports-20151120.tar.gz
cd backports-20151120
make defconfig-iwlwifi
make
sudo make install

Now we need the latest firmware. First, verify that you have these two files; iwlwifi-7265D-13.ucode and iwlwifi-7265-13.ucode:

ls /lib/firmware | grep 7265

If so, we are going to make copies but rename them:

cd /lib/firmware
sudo cp iwlwifi-7265D-13.ucode  iwlwifi-3165-9.ucode
sudo cp iwlwifi-7265-13.ucode  iwlwifi-3165-13.ucode

Reboot. Your wireless should be working.

You will need to recompile every time Update Manager installs a later kernel, known as linux-image. After the requested reboot, recompile:

cd backports-20151120
make clean
make defconfig-iwlwifi
make
sudo make install

Please retain the file and these instructions for that time.

5
  • Sorry i am not able to get *7265*13 files after issuing this command "ls /lib/firmware | grep 7265"
    – Ashu
    Commented Jan 20, 2016 at 17:01
  • Working for me now.
    – Ashu
    Commented Jan 21, 2016 at 0:54
  • 1
    After said instructions and "sudo modprobe iwlwifi" finally wifi started working. Many thanks Commented Feb 5, 2016 at 15:09
  • Thank you chilli55!! That worked perfectly. ls /lib/firmware | grep 7265 gave few more files, can those be left untouched? Also, please let us know if there are some additional steps that we need to follow while upgrading to next ubuntu release. I was certainly scared that my wifi would not work.. Thank you so much for the help. Really appreciate it..
    – Sandeep
    Commented Feb 16, 2016 at 23:44
  • @Manty You may safely leave the extra firmware files untouched. The driver will select the file it needs, typically the newest, without human intervention. When updating to the next release, the driver will probably already be included, as it is in 15.10 for example.
    – chili555
    Commented Feb 16, 2016 at 23:56
0

in case you are not able to find out where to get these files, please get it from the git repository:

git clone https://github.com/OpenELEC/iwlwifi-firmware.git

This solution worked for me temporarily. Permanent fix is to upgrade to kernel 4.1 as mentioned by Intel also(they certify that it works with 4.1 kernel)

0

Your post put me on the right track but didn't work. Instead of 7265-13 to make 3165-13 I needed 7265-12 to make 3165-12. Got it right reading budi5 post here.

  1. Downloaded the ucode for my Intel wifi device (3165) with 3.19+ kernel from here.

    cd ~/Downloads
    wget -c https://wireless.wiki.kernel.org/_media/en/users/drivers/iwlwifi-7265-ucode-25.17.12.0.tgz
    
  2. Renamed and copied the downloaded ucode files into /lib/firmware

    sudo cp ~/Downloads/iwlwifi-7265D-12.ucode /lib/firmware/iwlwifi-3165-9.ucode  
    sudo cp ~/Downloads/iwlwifi-7265-12.ucode /lib/firmware/iwlwifi-3165-12.ucode  
    
  3. Rebooted

    sud reboot
    
0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .