Hello ubuntu community!

Recently i downloaded and installed ubuntu, and after some experimenting, im unable do open my terminal!

The problem occurred after i gave the machine the following command:

sudo apt-get -o Dpkg::Options::="--force-overwrite" install locales

Now i can only open xTerm, and i can't copy/paste from it...

I already tried to apt-get purge gnome-terminal/apt-get install gnome-terminal, but i was unsuccessful in repairing it!

Please, i need your help!


This is the error i get when i try to execute gnome-terminal at xTerm:

Gtk-WARNING **: Locale not supported by C library.
Using the fallbac 'C' locale.
Error constructing proxy for org.gnome.Terminal: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.gnome.Terminal exited with status 8

Edit 2: Yes, indeed it may be a Locale problem... But i don't know how to fix it yet!

After i run sudo apt-get install language-pack-en-base it says the package is already installed, but when i sudo dpkg-reconfigure locales it gives me the below perl error:

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LC_TIME = "pt_BR.UTF-8",
    LC_MONETARY = "pt_BR.UTF-8",
    LC_CTYPE = "pt_BR.UTF-8",
    LC_ADDRESS = "pt_BR.UTF-8",
    LC_TELEPHONE = "pt_BR.UTF-8",
    LC_NAME = "pt_BR.UTF-8",
    LC_NUMERIC = "pt_BR.UTF-8",
    LC_PAPER = "pt_BR.UTF-8",
    LANG = (unset)
are suported and installed on your system.
perl: warning: Falling back to the standard locale ("C").

Anyone knows how to fix it?

  • 1
    What happens if you try to execute gnome-terminal from an xterm? are there any error messages? If so, please edit your question to include them. – steeldriver Dec 26 '15 at 23:50
  • Question edited! – Jacs Dec 27 '15 at 17:13
  • @Jacs - It states that you have messed up your locales - sudo apt-get install language-pack-en-base .Type the command and see if it worked. – Raphael Dec 27 '15 at 17:18
  • @Jacs - And then do this - sudo dpkg-reconfigure locales – Raphael Dec 27 '15 at 17:30
  • @Raphael Still not working... After some searching i found that this is a common problem to many users, and there is no good site with enough SEO to satisfy fixing it quickly – Jacs Jan 9 '16 at 4:13

All you need to do to fix this is regenerate the broken locale files. just do
sudo locale-gen
and check if the file
has the following 2 definitions LANG="en_US.UTF-8"
are set possibly with other LC_* values for the Time , Numeric, Monetary types of the country you're in.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.