0

So I installed the official version of Opera named "opera-stable" in the Ubuntu Software Center.

  • When I run it from launcher, it launches twice and displays a message (Translated to English by myself, may not be perfect):

Cannot read user configuration files. Some features may not be available and any changes performed this session will not be saved. (Print Screen Image)

  • When I run it from terminal, it throws these errors:

[1226/165646:ERROR:desktop_window_tree_host_x11.cc(889)] Not implemented reached in virtual void views::DesktopWindowTreeHostX11::InitModalType(ui::ModalType) [1226/165646:ERROR:download_history_importer.cc(50)] Failed to read a tag or its data. [1226/165646:ERROR:migration_assistant.cc(87)] Could not open file: wand.dat [1226/165646:ERROR:extensions_importer.cc(58)] Reading widgets.dat failed

  • Running it with the "sudo" command works perfectly well, and saves all user settings. Though from what I read so far, having to run a browser with sudo is not a good thing.

Now, I'm a newbie, but I followed this which recommends:

sudo chown -R group_name.user_name ~/.opera

and indeed I seem to be the owner of all the folders and subfolders that opera uses (I can't remember the command I used to check that) but it still doesn't work.

I also tried loads of other things like updating, upgrading, apt-mark hold command, reinstalling opera (both using the software center and manually unpacking .deb file) and maybe something more. As I said, I'm a newbie, I only use Ubuntu for 2 days, I just want to get Opera up and running properly, but I spent those 2 days looking for an answer.

Any idea?

Edit:

Here's a screenshot of .opera's permissions. Sorry for the language. I should switch to English.

  • Right-click on .opera > Properties > Permissions and then edit your answer with the screenshot – Raphael Dec 26 '15 at 16:58
  • Do you remember running this command - sudo nautilus ? – Raphael Dec 26 '15 at 17:01
  • Ehm, could you tell me where do I find ".opera"? And no, I've never seen the nautilus command – swifterik Dec 26 '15 at 17:02
  • Goto` /home/<username>` and then press Ctrl + H – Raphael Dec 26 '15 at 17:03
  • Added screenshot. Should I change everything to "creating and deleting files"? – swifterik Dec 26 '15 at 17:10
0

First launch nautilus as root. To do that type the following:

gksu nautilus

Then right-click on /home/<username>/.opera and click on Properties, then to Permissions.

If you are unable to find .opera then press Ctrl + H to show the folder.

Now, change

Owner to <username>

Group to <username>

And all else to:

1

Also, check similarly for your /home & /home/<username> folders.

EDIT: Also, change the permissions of the following folders to the one as shown in your shared screenshot:

/home/<username>/.cache/opera

&

/home/<username>/.config/opera

2

  • Thanks. I did what you said but unfortunutely it didn't work. The error message still pops up when I run Opera, and the terminal still displays error messages before running Opera. – swifterik Dec 26 '15 at 17:42
  • @swifterik - checking, will reply in a few minutes – Raphael Dec 26 '15 at 17:43
  • @swifterik - edited!! – Raphael Dec 26 '15 at 17:56
  • Both config and cache are alredy set like this. Maybe I should set them to access file as well? – swifterik Dec 26 '15 at 18:07
  • opera inside config and cache? – Raphael Dec 26 '15 at 18:08
0

I gave up, reinstalled Ubuntu and installed Opera from opera.com and it works OK. Hopefully it's rare for this problem to occur. I must've done something terribly wrong to cause that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.