5

When I heard Saints Row 4 is now compatible with SteamOS I had to jump right on it but when I finished installing and then tried to run the game, I got this error message. Does anyone know how I can fix this?enter image description here

  • 3
    What graphics card and driver version? – muru Dec 26 '15 at 11:21
  • 1
    If you want to fix it, implement OpenGL support for that GPU. – mikewhatever Dec 26 '15 at 12:41
2

It comes down to what graphics driver you have installed. By default, Ubuntu will install a driver based on Mesa, which does not support OpenGL 4.1. To get full support, you need to install a proprietary driver for your GPU.

With that being said, you will have to install the proper driver yourself. Check here: https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers

or simply:

sudo add-apt-repository ppa:oibaf/graphics-drivers
sudo apt-get update
sudo apt-get upgrade

After that restart your computer. Try launching the game again. It should work!

  • 1
    What do I do if this didn't work? I have an NVidia 630M – michaelAdam May 13 '16 at 20:45
  • I concur. I've installed the PPA, but glxinfo still reports "OpenGL version string: 3.0 Mesa 17.3.0-devel" and Saints Row 4 still reports the same dialog as the OP showed. I have an HD 6850 which should support OpenGL 4.4. – bambams Aug 17 '17 at 0:02
0

Try this ppa for OpenGL 4.1 :

https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.