0

I'm new to Web App Development beginning with Ruby On Rails. To get started I followed this.

I'm in the final steps where it asks to create a Database (I'm using mysql) by running rake db:create but I get the following error. enter image description here

Below I have pasted my Gemfile and Gemfile.lock files. Please advice if you need anything else.

urce 'https://rubygems.org'

gemspec

We need a newish Rake since Active Job sets its test tasks' descriptions.

gem 'rake', '>= 10.3'

Active Job depends on the URI::GID::MissingModelIDError, which isn't released yet.

gem 'globalid', github: 'rails/globalid', branch: 'master' gem 'rack', github: 'rack/rack', branch: 'master'

This needs to be with require false as it is

loaded after loading the test library to

ensure correct loading order

gem 'mocha', '~> 0.14', require: false

gem 'rack-cache', '~> 1.2' gem 'jquery-rails', github: 'rails/jquery-rails', branch: 'master' gem 'coffee-rails', '~> 4.1.0' gem 'turbolinks' gem 'arel', github: 'rails/arel', branch: 'master' gem 'mail', github: 'mikel/mail', branch: 'master'

gem 'sprockets', github: 'rails/sprockets', branch: 'master' gem 'sprockets-rails', github: 'rails/sprockets-rails', branch: 'master' gem 'sass-rails', github: 'rails/sass-rails', branch: 'master'

require: false so bcrypt is loaded only when has_secure_password is used.

This is to avoid ActiveModel (and by extension the entire framework)

being dependent on a binary library.

gem 'bcrypt', '~> 3.1.10', require: false

This needs to be with require false to avoid

it being automatically loaded by sprockets

gem 'uglifier', '>= 1.3.0', require: false gem 'sass', '>= 3.3', require: false

group :doc do gem 'sdoc', '~> 0.4.0' gem 'redcarpet', '~> 3.2.3', platforms: :ruby gem 'w3c_validators' gem 'kindlerb', '0.1.1' end

ActiveSupport

gem 'dalli', '>= 2.2.1'

ActiveJob

group :job do gem 'resque', require: false gem 'resque-scheduler', require: false gem 'sidekiq', require: false gem 'sucker_punch', require: false gem 'delayed_job', require: false gem 'queue_classic', github: "QueueClassic/queue_classic", branch: 'master', require: false, platforms: :ruby gem 'sneakers', require: false gem 'que', require: false gem 'backburner', require: false gem 'qu-rails', github: "bkeepers/qu", branch: "master", require: false gem 'qu-redis', require: false gem 'delayed_job_active_record', require: false gem 'sequel', require: false end

Add your own local bundler stuff

local_gemfile = File.dirname(FILE) + "/.Gemfile" instance_eval File.read local_gemfile if File.exist? local_gemfile

group :test do # FIX: Our test suite isn't ready to run in random order yet gem 'minitest', '< 5.3.4'

platforms :mri do gem 'stackprof' gem 'byebug' end

gem 'benchmark-ips' end

platforms :ruby do gem 'nokogiri', '>= 1.4.5'

# Needed for compiling the ActionDispatch::Journey parser gem 'racc', '>=1.4.6', require: false

# ActiveRecord gem 'sqlite3', '~> 1.3.6'

group :db do gem 'pg', '>= 0.18.0' gem 'mysql', '>= 2.9.0' gem 'mysql2', '>= 0.4.0', github: 'brianmario/mysql2' end end

platforms :jruby do gem 'json' if ENV['AR_JDBC'] gem 'activerecord-jdbcsqlite3-adapter', github: 'jruby/activerecord-jdbc-adapter', branch: 'master' group :db do gem 'activerecord-jdbcmysql-adapter', github: 'jruby/activerecord-jdbc-adapter', branch: 'master' gem 'activerecord-jdbcpostgresql-adapter', github: 'jruby/activerecord-jdbc-adapter', branch: 'master' end else gem 'activerecord-jdbcsqlite3-adapter', '>= 1.3.0' group :db do gem 'activerecord-jdbcmysql-adapter', '>= 1.3.0' gem 'activerecord-jdbcpostgresql-adapter', '>= 1.3.0' end end end

platforms :rbx do # The rubysl-yaml gem doesn't ship with Psych by default # as it needs libyaml that isn't always available. gem 'psych', '~> 2.0' end

gems that are necessary for ActiveRecord tests with Oracle database

if ENV['ORACLE_ENHANCED'] platforms :ruby do gem 'ruby-oci8', '~> 2.1' end gem 'activerecord-oracle_enhanced-adapter', github: 'rsim/oracle-enhanced', branch: 'master' end

A gem necessary for ActiveRecord tests with IBM DB

gem 'ibm_db' if ENV['IBM_DB']

GEMFILE.lock

remote: https://rubygems.org/ specs: actionmailer (4.2.4) actionpack (= 4.2.4) actionview (= 4.2.4) activejob (= 4.2.4) mail (~> 2.5, >= 2.5.4) rails-dom-testing (~> 1.0, >= 1.0.5) actionpack (4.2.4) actionview (= 4.2.4) activesupport (= 4.2.4) rack (~> 1.6) rack-test (~> 0.6.2) rails-dom-testing (~> 1.0, >= 1.0.5) rails-html-sanitizer (~> 1.0, >= 1.0.2) actionview (4.2.4) activesupport (= 4.2.4) builder (~> 3.1) erubis (~> 2.7.0) rails-dom-testing (~> 1.0, >= 1.0.5) rails-html-sanitizer (~> 1.0, >= 1.0.2) activejob (4.2.4) activesupport (= 4.2.4) globalid (>= 0.3.0) activemodel (4.2.4) activesupport (= 4.2.4) builder (~> 3.1) activerecord (4.2.4) activemodel (= 4.2.4) activesupport (= 4.2.4) arel (~> 6.0) activesupport (4.2.4) i18n (~> 0.7) json (~> 1.7, >= 1.7.7) minitest (~> 5.1) thread_safe (~> 0.3, >= 0.3.4) tzinfo (~> 1.1) arel (6.0.3) binding_of_caller (0.7.2) debug_inspector (>= 0.0.1) builder (3.2.2) byebug (8.2.1) coffee-rails (4.1.1) coffee-script (>= 2.2.0) railties (>= 4.0.0, < 5.1.x) coffee-script (2.4.1) coffee-script-source execjs coffee-script-source (1.10.0) concurrent-ruby (1.0.0) debug_inspector (0.0.2) erubis (2.7.0) execjs (2.6.0) globalid (0.3.6) activesupport (>= 4.1.0) i18n (0.7.0) jbuilder (2.3.2) activesupport (>= 3.0.0, < 5) multi_json (~> 1.2) jquery-rails (4.0.5) rails-dom-testing (~> 1.0) railties (>= 4.2.0) thor (>= 0.14, < 2.0) json (1.8.3) loofah (2.0.3) nokogiri (>= 1.5.9) mail (2.6.3) mime-types (>= 1.16, < 3) mime-types (2.99) mini_portile2 (2.0.0) minitest (5.8.3) multi_json (1.11.2) mysql2 (0.4.2) nokogiri (1.6.7.1) mini_portile2 (~> 2.0.0.rc2) rack (1.6.4) rack-test (0.6.3) rack (>= 1.0) rails (4.2.4) actionmailer (= 4.2.4) actionpack (= 4.2.4) actionview (= 4.2.4) activejob (= 4.2.4) activemodel (= 4.2.4) activerecord (= 4.2.4) activesupport (= 4.2.4) bundler (>= 1.3.0, < 2.0) railties (= 4.2.4) sprockets-rails rails-deprecated_sanitizer (1.0.3) activesupport (>= 4.2.0.alpha) rails-dom-testing (1.0.7) activesupport (>= 4.2.0.beta, < 5.0) nokogiri (~> 1.6.0) rails-deprecated_sanitizer (>= 1.0.1) rails-html-sanitizer (1.0.2) loofah (~> 2.0) railties (4.2.4) actionpack (= 4.2.4) activesupport (= 4.2.4) rake (>= 0.8.7) thor (>= 0.18.1, < 2.0) rake (10.4.2) rdoc (4.2.1) json (~> 1.4) sass (3.4.20) sass-rails (5.0.4) railties (>= 4.0.0, < 5.0) sass (~> 3.1) sprockets (>= 2.8, < 4.0) sprockets-rails (>= 2.0, < 4.0) tilt (>= 1.1, < 3) sdoc (0.4.1) json (~> 1.7, >= 1.7.7) rdoc (~> 4.0) spring (1.6.1) sprockets (3.5.2) concurrent-ruby (~> 1.0) rack (> 1, < 3) sprockets-rails (3.0.0) actionpack (>= 4.0) activesupport (>= 4.0) sprockets (>= 3.0.0) thor (0.19.1) thread_safe (0.3.5) tilt (2.0.1) turbolinks (2.5.3) coffee-rails tzinfo (1.2.2) thread_safe (~> 0.1) uglifier (2.7.2) execjs (>= 0.3.0) json (>= 1.8.0) web-console (2.2.1) activemodel (>= 4.0) binding_of_caller (>= 0.7.2) railties (>= 4.0) sprockets-rails (>= 2.0, < 4.0)

PLATFORMS ruby

DEPENDENCIES byebug coffee-rails (~> 4.1.0) jbuilder (~> 2.0) jquery-rails mysql2 rails (= 4.2.4) sass-rails (~> 5.0) sdoc (~> 0.4.0) spring turbolinks uglifier (>= 1.3.0) web-console (~> 2.0)

BUNDLED WITH 1.11.2

0

I uninstalled Ruby version 2.2.3 and installed 2.2.4, which sorted the issue!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.