0

I'm running Ubuntu 15.10 in my PC in dual boot mode along with Win 10. I have been trying to use my WD external HDD, but an error is preventing me from doing so. This is what pops up when I connect the HDD via USB:

Error mounting /dev/sdb1 at /media/mahendranath/My Passport: Command-line `mount -t "exfat" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,iocharset=utf8,namecase=0,errors=remount-ro,umask=0077" "/dev/sdb1" "/media/mahendranath/My Passport"' exited with non-zero exit status 32: mount: unknown filesystem type 'exfat'

On the other hand, I'm able to connect and use the HDD quite well in Win 10. What may be the reason for this and how I fix it? Thanks :)

1

As it's been mentioned in the error:

unknown filesystem type 'exfat'

It means that you don't have the exfat file system.

To install exfat, do:

sudo apt-get install exfat-fuse exfat-utils

You should now be able to mount your external HDD.

Also, you might need to reboot your PC for the changes to take effect.

  • It worked! Thanks a ton, Raphael :) – Mahendra Dec 26 '15 at 5:10
  • Glad! I could help. Also, since it answered your question, can you please upvote and accept my answer. – Raphael Dec 26 '15 at 5:11
  • @Mahendra - You are welcome! – Raphael Dec 27 '15 at 2:45

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.