I have Ubuntu 14.04 duel boot on an Dell Inspiron 7559 laptop with Windows 10. My graphic card is NVIDIA® GeForce® GTX 960M 4GB GDDR5

I installed NVIDIA video card driver following this question. And I choose the driver NVIDIA binary driver version 358.16. enter image description here

The problem is, my laptop could not recover from suspend. The laptop will show a color vertical stripes after recovery. Then the system has no response. Ctrl+Alt+F1 etc don't work either. I have to hard reboot the laptop.

I realize that in the GeForce video card driver's information page, they claim that this is sort of a known issue.

Known Issues with this release:

  • Resuming from suspend may not be reliable on GeForce GTX 9xx boards in some configurations.

Note that many Linux distributions provide their own packages of the NVIDIA Linux Graphics Driver in the distribution's native package management format. This may interact better with the rest of your distribution's framework, and you may want to use this rather than NVIDIA's official package.

Therefore, I believe my suspend problem is due to the video card driver. Then, my question is, as the NVIDIA website mentioned, is there Ubuntu's own packages fo the graphic driver for GTX960M? If so, where can I find them?

I tried the first driver in the list. The system will completely dead once a few minutes. My hibernate feature also doesn't work. I do have enough swap space. For more than half of the time, the laptop cannot recover from hibernate and get stuck at a black screen with a flashing curse. Therefore, I really want to solve this problem. Otherwise I cannot carry my laptop around without turn it off.

Since Khalid Abu Shawarib says he have similar video setting as I do and his laptop can recover from suspend, is there any other possible issue that may cause the failure of suspend?

A bit more information, my kernel is 4.1.0-040100-generic

  • Possible duplicate of Infinite login loop with Nvidia proprietary graphics
    – mowen
    Apr 1 '16 at 2:15
  • Although mowen's answer solved my problem, the system still not work very fluently. But all problems solved almost automatically after I installed the 16.04 LTS version instead . So if you encountered similar problem, I strongly suggest to upgrade the OS if possible.
    – HD189733b
    Apr 28 '16 at 16:41

I don't have enough rep to comment. I got Xubuntu 15.10 working on my Inspiron 15 7559, which has a GeForece GTX 960M, with functional suspend mode and the ability to switch between integrated and discrete graphics.

See my answer here:

Another similar question:

Edit: Removed duplicate content. I learned it is bad practice to post duplicate answers to related questions. Fixed link

  • Hi mowen, I learned it is bad practice to post duplicate answers to related questions. That's right, you should just make sure that there is enough context provided even if the link(s) should expire. With a rep of 15 you will be able to flag for duplicates (in case you find them) .
    – bummi
    Feb 27 '16 at 8:15
  • Thanks. I'm currently using Ubuntu 14.04 and I don't plan to spend time on upgrading to 15.10. It seems that the 14.04 doesn't accept archive.ubuntu.com/ubuntu xenial. I'll try your method after I install ubuntu 16.04 LTS when it comes out. BTW, the link of the similar question you mentioned direct to this question itself. Did you copy the incorrect link?
    – HD189733b
    Feb 28 '16 at 18:18
  • Sorry, the command for adding the xenial repo was missing an argument. I fixed it and believe it should work now for all versions of Ubuntu. I also fixed the circular link you noticed. Thanks @HD189733b.
    – mowen
    Feb 29 '16 at 2:31
  • It works! I'd like to give 10 up votes if I could. I'm using Ubuntu 14.04. I can't login after changing grub menu in step 2, so I ignored it at the beginning. After I finished the rest part of the setting and reboot my laptop, the moniter keeps black after recovering from the suspend mode, different from the color strip I got previously. Then I modified the grub again. The suspend works perfectly after that. In the original liren's answer, he mentioned the HDMI output is broken after this modification. Luckily, HDMI works find for me.
    – HD189733b
    Mar 2 '16 at 15:23
  • The only problem to me of this solution is that sometime the webpage could not scroll smoothly. The content may blink and jump around slightly when I scroll the page.
    – HD189733b
    Mar 3 '16 at 11:27

The version that Ubuntu currently ship is 352.63. There are 2 packages. The one called "nvidia-352" and the other is "nvidia-352-updates" (Most if the time they have different versions but that's not the case currently). This is Nvidia's current long-lived driver branch (aka stable driver).

I have the same card as yours but on 15.10 and 358.16 driver. When the computer return from suspend it sometimes make artifacts in the apps that stores textures on the gpu but the computer is completly responsive.

  • Thank you for your answer. I tried nvidia-352 at the beginning and it didn't work. Then I installed the other two drivers. Maybe its not the issue of video card driver?
    – HD189733b
    Dec 28 '15 at 7:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.