7

By default Ubuntu has selected the nouveau drivers as i have an nvidia gpu. But I need to run my system on the Intel GPU instead, with Intel drivers etc. How can I do this?

6
  • 2
    this one? askubuntu.com/questions/449530/…
    – fossfreedom
    Dec 25, 2015 at 9:36
  • install Prime Indicator Dec 25, 2015 at 9:40
  • i just tried prime-indicator. it still switches me to nvidia graphics
    – raaj
    Dec 25, 2015 at 10:42
  • doing lspci | grep VGA yeilds only my Nvidia card. How can I install my intel drivers
    – raaj
    Dec 25, 2015 at 10:48
  • @raaj after you switch from prime indicator you have to logout and login back Dec 25, 2015 at 10:50

2 Answers 2

3
+200

To achieve what you want, you will have to install the proprietary NVIDIA drivers and Optimus.
After that you can switch between the graphics from NVIDIA X Server Settings PRIME Profiles.
Assuming you have a NVIDIA GEFORCE 400 series adapter or newer execute these commands :

sudo apt-get update
sudo apt-get install nvidia-352 nvidia-prime
sudo reboot  

Update addressing your response to having problems with 352 drivers

Use another method - first uninstall the formerly installed NVIDIA drivers.
Highlight the Ubuntu entry in the GRUB boot menu and press the E key.
Add nouveau.modeset=0 to the end of the linux line - press F10 to boot.

On login screen press Ctrl+Alt+F1 - enter user name and password - execute :

sudo apt-get purge nvidia*  
sudo reboot  

Now install the NVIDIA drivers 358 from the Proprietary GPU Drivers PPA.
Highlight the Ubuntu entry in the GRUB boot menu and press the E key.
Add nouveau.modeset=0 to the end of the linux line - press F10 to boot.

On login screen press Ctrl+Alt+F1 - enter user name and password - execute :

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-358 nvidia-prime
sudo reboot
16
  • 1
    he wants to use intel drivers. And he does not wants nvidia drives installed but want to switch to intel drivers Dec 25, 2015 at 11:49
  • I did exactly as above. same issue, attempting switching using prime-select doesn't work, still stuck on nvidia. Also, my nvidia control panel does not have PRIME Profiles
    – raaj
    Dec 25, 2015 at 11:50
  • @edwardtorvalds : Then the only way to do this is to deactivate the NVIDIA card in BIOS ... in case this is possible ... otherwise you have to install the proprietary drivers. :)
    – cl-netbox
    Dec 25, 2015 at 11:52
  • No i cannot do this. Could it be a driver issue? Perhaps if i downgrade from 352 to something lower prime profiles may work superuser.com/questions/998403/…
    – raaj
    Dec 25, 2015 at 11:53
  • which other answer
    – raaj
    Dec 25, 2015 at 11:57
1

Nvidia settings is available in software center. Install it if not already installed.

sudo apt install nvidia-settings

Now open it by running this in terminal

nvidia-settings

From there you will be able to select which GPU you want to use (Nvidia/Intel).

Go to PRIME Profiles -> Select the GPU you would like to use -> Choose Intel (Power Saving Mode)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.