0

I'm currently on Ubuntu Mate 15.04 and have installed Eclipse Mars directly from the official website.

My Eclipse version: Eclipse IDE for C/C++ Developers Version: Mars.1 Release (4.5.1) Build id: 20150924-1200

Unfortunately, when I'm trying to use it, after clicking on some button (for example doing a right click on the C/C++ button in the top right corner) get me to a crash.

I then get a crash report (.log) in my /home file with written :

#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007f9f09801d41, pid=14037, tid=140321501198080
#
# JRE version: Java(TM) SE Runtime Environment (8.0_66-b17) (build 1.8.0_66-b17)
# Java VM: Java HotSpot(TM) 64-Bit Server VM (25.66-b17 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  [libgdk-3.so.0+0x3dd41]  gdk_window_ensure_native+0x31
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# If you would like to submit a bug report, please visit:
#   http://bugreport.java.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#

There are actually about 1500 lines in those log files. From the crash report, the problem comes from Java. I have installed Java 7 and Java 8. Tried to uninstall one to have only one at a time, still crash.

From what I have read, there may be some bugs because of GTK or something like that but I still don't know what to do to fix it. Do you have any idea ?

Thanks forward :)

0

First of all, it gives you a PID, or process ID, so go into a task manager to check which specific process is causing the error. Assuming it's a problem with the runtime, the best advice for you would be to completely uninstall all java versions. As of right now, the log isn't specific enough. Edit: Perhaps your version of libgdk is outdated, and could be upgraded via

sudo apt-get upgrade

Otherwise, I'd suggest removing libgdk and installing the latest version, which most likely will not cause the crash.

  • I actually already tried to uninstall all java versions, and install them again but got again and again the same crashes. – yohkz Dec 25 '15 at 9:48
  • Okay, well it seems that libgdk is what's causing the crashes, probably because some of the java natives libraries are having compatibility issues – Andrew Lalis Dec 25 '15 at 11:07
  • Thanks for your answer. The upgrade did not solve the issue. How do I remove libgdk and install the last version ? – yohkz Dec 25 '15 at 11:24
  • sudo apt-get remove libgdk -That removes it, and you'd do sudo apt-get install libgdk to reinstall the latest version. – Andrew Lalis Dec 25 '15 at 11:27
  • It is telling me that he doesnt find the paquage. When I try to uninstall it and even when I try to install it... – yohkz Dec 25 '15 at 11:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.