0

Today I've installed Ubuntu 15.10 and I can't using internet with wireless connection. In connection information is written that I'm connected, but I can't do anything. When I'm connected with cable everything is well. I tried to connect my WiFi dongle, which I'm using in raspberry pi and everything is working aswell. Here is my ifconfig with WiFi dongle:

enp2s0    Link encap:Ethernet  HWaddr 00:26:2d:50:42:db  
      UP BROADCAST MULTICAST  MTU:1500  Metric:1
      RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
      Interrupt:16 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:2468 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2468 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:247229 (247.2 KB)  TX bytes:247229 (247.2 KB)

wlp3s0    Link encap:Ethernet  HWaddr 00:17:c4:b5:11:06  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:129 errors:0 dropped:0 overruns:0 frame:0
          TX packets:413 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:18927 (18.9 KB)  TX bytes:44320 (44.3 KB)

wlx243c200d02b2 Link encap:Ethernet  HWaddr 24:3c:20:0d:02:b2  
          inet addr:192.168.0.109  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::263c:20ff:fe0d:2b2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:12989 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11258 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:10695403 (10.6 MB)  TX bytes:1594026 (1.5 MB)

lspci -nnk | grep -iA2 net command output:

02:00.0 Ethernet controller [0200]: Broadcom Corporation NetLink BCM5784M Gigabit Ethernet PCIe [14e4:1698] (rev 10)
Subsystem: Acer Incorporated [ALI] Device [1025:0207]
Kernel driver in use: tg3

03:00.0 Network controller [0280]: Qualcomm Atheros AR928X Wireless Network Adapter (PCI-Express) [168c:002a] (rev 01)
Subsystem: Quanta Microsystems, Inc EM306 802.11bgn Wireless Half-size Mini PCIe Card [AR9283] [1a32:0306]
Kernel driver in use: ath9k

lshw -c net command output:

*-network               
   description: Ethernet interface
   product: NetLink BCM5784M Gigabit Ethernet PCIe
   vendor: Broadcom Corporation
   physical id: 0
   bus info: pci@0000:02:00.0
   logical name: enp2s0
   version: 10
   serial: 00:26:2d:50:42:db
   capacity: 1Gbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.137 firmware=sb v2.19 latency=0 link=no multicast=yes port=twisted pair
   resources: irq:32 memory:f4100000-f410ffff
*-network
   description: Wireless interface
   product: AR928X Wireless Network Adapter (PCI-Express)
   vendor: Qualcomm Atheros
   physical id: 0
   bus info: pci@0000:03:00.0
   logical name: wlp3s0
   version: 01
   serial: 00:17:c4:b5:11:06
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=ath9k driverversion=4.3.3-040303-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
   resources: irq:17 memory:f4200000-f420ffff

http://paste.ubuntu.com/14257243/

  • Please edit the question to include results from lspci -nnk | grep -iA2 net Thanks – Jeremy31 Dec 24 '15 at 14:43
  • DId the wireless connection worked when installing ubuntu? – albertoefg Dec 24 '15 at 18:07
  • @albertoefg It wasn't working. – Patryk Tabiś Dec 25 '15 at 9:47
  • Is your wifi access point using WPA2 encryption only or is it using a mixed mode. check iwlist scan | egrep -i 'ssid|cipher' Find your access points name and see if the group and pairwise ciphers show CCMP only – Jeremy31 Dec 25 '15 at 11:37
  • @Jeremy31 I'vr got no encryption and iwlist scan | egrep -i 'ssid|cipher' giving no cipher on my access point – Patryk Tabiś Dec 25 '15 at 19:09
0

You should set your country code and the script results would indicate you are in Poland

sudo iw reg set PL

Then we will change the crda file gksudo gedit /etc/default/crda

The last line of the file needs to be

REGDOMAIN=PL

Save file and exit gedit. Then use Network Manager connection settings and set the IPv6 to ignore for your connection and in IPv4 settings add DNS of 8.8.8.8 and save. Reboot and see if you can have any connectivity

  • I can ping myself but not access point or other devices. – Patryk Tabiś Dec 30 '15 at 20:10
  • Try sudo dpkg-reconfigure resolvconf – Jeremy31 Dec 30 '15 at 21:52
  • Still nothing... – Patryk Tabiś Dec 30 '15 at 22:04
  • Try booting into the 4.2 kernel as I don't think 4.3 is an Ubuntu kernel – Jeremy31 Dec 30 '15 at 22:33
  • Now I'm using 4.2 kernel and it's not working. I tried manually config and it wasn't working too. – Patryk Tabiś Dec 30 '15 at 22:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.