0

Clean install of Kubuntu 15.10 on ASUS UX305CA laptop (uses the Elantech touchpad) and the touchpad will not work at all. It does not recognize single tap, double tap, two finger scroll, or any clicking actions. Basically, the touchpad doesn't even exist.

This is a dual-boot and the touchpad works fine on the Windows 10 side.

I installed updates and checked versions: kernel is 4.2, plasma is 5.4.2, and QT is 5.5.2

I tried:

sudo apt-get install xserver-xorg-input-synaptics

and it tells me that my synaptics version is already the latest installed. So then, I do a sudo apt-get update followed by a reboot and same thing.

I tried:

sudo modprobe -r psmouse

sudo modprobe psmouse proto=imps

Again, no beans. I even purged the synaptics driver package and re-installed followed by apt-get update and a reboot and still nothing.

Pilot6 has made a fix for the focaltech models but that doesn't carry over and is obsolete after kernel version 3.19 anyway.

Finally, I keyboarded my over to system settings->input devices->touchpad and there is a red box with a message that says "Synaptics backend not found"

What I haven't tried is:

cat /proc/bus/input/devices

because that is a little too technical for me to understand anyway. Any ideas??? Thanks in advance.

  • Update: I did xinput -list and elantech was not listed. It only listed a virtual core pointer. Virtual core XTEST pointer id=4 slave pointer – Greg Dec 24 '15 at 5:12
  • I also looked at cat /proc/bus/input/devices | grep Name and no elantech or anything related to touchpad, just power button, hotkeys, video bus, webcam, and headphones – Greg Dec 24 '15 at 5:19
0

I am using Ubuntu 15.10, not Kubuntu, but I was was able to get the touchpad functional by compiling a custom kernel with one change. My understanding is that Kubuntu and Ubuntu really only differ in the Desktop Manager (KDS vs. Unity or GNOME) so I would think the kernel fix should work for you as well.

I am not a real expert either, but I found the guide to doing so here:

https://florisvanvugt.wordpress.com/2015/12/26/making-asus-ux305ca-touchpad-work-in-ubuntu/comment-page-1/#comment-17

I ended up pulling down the 4.4-rc8 kernel from the repo and building that (instructions via a different URL at the link provided) after making the one line modification and so far the touchpad is working as expected, tap, scroll, etc.

Hopefully this would be a solution for you as well.

  • You are the man, @Phil!! This worked for me on Kubuntu 15.10. I also used the latest upstream 4.4-rc8. The touchpad is working wonderfully. Thank you. For anyone else viewing this, the workaround in Phil's link is as of Jan 2016. Supposedly this will be a permanent fix for kernel 4.5 so if you are viewing after the release of 4.5 just boot into that one. – Greg Jan 9 '16 at 0:56
0

I recently upgraded to Ubuntu 15.10 and my Elantech Touchpad on my Acer Aspire Laptop stopped working completely. To my surprise I couldn't even find it in the hardware devices. After exhausting fails I made a small discovery that lead me to a fix.

After running DMESG and finding around the 3.5 mark when it initialized devices it mentioned an error in the PNP / TAP timing and had a note saying try running with "i8042.nopnp". (NO Device info was present, just the pnp/tap)

I edited the /etc/default/grub Added the recommended line to my entry to look like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.nopnp"

Saved the file and ran:

sudo update-grub

Rebooted and hit the function key + touchpad to enable/disable it and it worked exactly as expected to after. I noticed now in the DMESG that the timing error is gone. I mention looking at your DMESG output for that line because it's possible a different computer will have a different number in front of the .nopnp in "i8042.nopnp" that will need to be added to your grub entry.

I spent half a day trying other stuff with no success and I wanted to make sure this made it into the realm of things to try. I was able to remove the line and confirm it stopped working, add the line again and touchpad was working as expected.

This was a 100% fresh install of Ubuntu 15.10, the touchpad DID NOT work even in the setup and I used an external usb mouse to get me started. No system modifications were done at anytime, just installed and went straight to fixing the touchpad. Kernel Version is 4.4.2.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.