I am trying to upgrade my apache2 php on Ubuntu 15.10 from php5 to php7. I've read a lot of instructions, but did not understand how to do it, because a lot of instructions are for Ubuntu 14 and so some "apt-get" commands are not working.

What do I need to do on Ubuntu 15.10 to upgrade my apache's php version to php7? When trying to run

sudo add-apt-repository ppa:ondrej/php-7.0

I am getting the error: "ValueError: SSL support not available "

When trying to self compile, I get the following error when running "make":

libtool: link: `ext/gd/libgd/wbmp.lo' is not a valid libtool object
Makefile:288: recipe for target 'sapi/fpm/php-fpm' failed
make: *** [sapi/fpm/php-fpm] Error 1

I came to the cinclusion to install Ubuntu 14 lts, because Ubuntu 15 sucks a lot...

2 Answers 2


php7 is not in the "default" repositories of Ubuntu 15.10, which leaves youn with at least two options:

  1. Use a ppa anyways
    • use ppa:ondrej/php if you want php5 and php7 to coexist
  2. Compile php7 yourself
  • updated my question with some "error reports" from things i've tried. Dec 24, 2015 at 0:23

Your are probably missing HTTPS support in apt. So run sudo apt-get install apt-tranport-https before adding the PPA.

  • already installed, still getting the same error. It is thrown at "File "/usr/lib/python3.4/urllib/request.py", line 148, in urlopen raise ValueError('SSL support not available')"..Ubuntu15 sucks Dec 24, 2015 at 11:31
  • That package is not found on my Ubuntu 15.10 Jul 24, 2017 at 15:41
  • Ubuntu 15.10 eoled more than year ago. fridge.ubuntu.com/2016/07/28/…
    – oerdnj
    Jul 24, 2017 at 15:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .