I've been trying to run AtomicTV on my 10.04 install, but I've had some Ruby issues that I'm having trouble parsing and haven't been able to find help with via Google. I installed the Ruby gems packages, and libopenssl-ruby, which sounded like it might have been the problem, but doesn't seem to have changed.

Trying to run AtomicTV throws this error:

/usr/local/lib/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require': no such file to load -- net/https (LoadError)
    from /usr/local/lib/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /usr/lib/ruby/gems/1.9.1/gems/httparty-0.8.1/lib/httparty.rb:3:in `<top (required)>'
    from /usr/local/lib/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /usr/local/lib/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /usr/lib/ruby/gems/1.9.1/gems/tvdb_party-0.6.0/lib/tvdb_party.rb:2:in `<top (required)>'
    from /usr/local/lib/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /usr/local/lib/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /usr/lib/ruby/gems/1.9.1/gems/AtomicTV-1.0.2/lib/AtomicTV.rb:7:in `<top (required)>'
    from /usr/local/lib/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /usr/local/lib/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /usr/lib/ruby/gems/1.9.1/gems/AtomicTV-1.0.2/bin/AtomicTV:3:in `<top (required)>'
    from /usr/bin/AtomicTV:19:in `load'
    from /usr/bin/AtomicTV:19:in `<main>'

Anybody have any suggestions? Alternatively, does anybody know any good command line software that can pull tags from TheTVDB?


1 Answer 1


The official repositories for Ubuntu 10.04 contain only Ruby 1.8, but it appears that you're using a manual installation of Ruby 1.9.1. When you install libopenssl-ruby using Ubuntu's package manager, libopenssl is installed for Ruby 1.8 within /usr/lib/ruby/1.8/, but you need it to be installed for Ruby 1.9.1 within /usr/local/lib/site_ruby/1.9.1/.

How you achieve this will depend on how you originally installed Ruby 1.9.1.

If you're not strongly attached to a particular method of installing Ruby, my suggestion is to reinstall it using the Ruby Version Manager (RVM), which is advocated on the official Ruby download page. Installing Ruby using RVM should include the required libopenssl library automatically.

I recommend reading over the RVM installation instructions first (it's not as long as it looks—it's half examples), but this is probably all you'll need to do:

  1. Install dependencies for RVM:

    sudo apt-get install git curl
  2. Install RVM:

    bash < <(curl -s https://raw.github.com/wayneeseguin/rvm/master/binscripts/rvm-installer )
    echo '[[ -s "$HOME/.rvm/scripts/rvm" ]] && . "$HOME/.rvm/scripts/rvm" # Load RVM function' >> ~/.bashrc
    source .bashrc
  3. Install dependencies for Ruby:

    Scroll up (or run rvm requirements) and look for the line that says For Ruby … install the following:. Copy, paste, and run with sudo the apt-get install … line beneath it.

  4. Install Ruby:

    rvm install 1.9.3
    rvm use 1.9.3 --default

    You could install Ruby 1.9.1 here instead, but Ruby 1.9.3 is the current recommended version and should be compatible with nearly anything that works on other Ruby 1.9.x versions.

  5. Install AtomicTV:

    gem install AtomicTV

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .