0

I updated my 14.05 with Vivid 15.04 HWE stack yesterday and now it does not work. I tried thing that worked for me in the past and that was uninstalling the nvidia driver and installing it again. Then it magically worked once again (I suspect it was DKMS module).

Now I cannot load Xorg. It just does not load and the system loading is stoppend on this step. I tried reinstalling as I mentiond and also installing the newest drivers from ppa:graphics-drivers/ppa and these are showing the same result. With removal of xorg.conf. I also tried to purge nvidia drivers and revert to nouveau, but this does not work so. Surprisingly if I unmount my Nvidia driver from PCI slot and plug HDMI for Intel GPU the system works.

The best possible solution would be how to revert back to nouveau driver. Thanks in forward.

  • How did you purge the drivers ? To remove them completely run sudo apt-get purge nvidia*, perhaps some part was left over if you used something like sudo apt-get purge nvidia-352??? – Mark Kirby Dec 23 '15 at 11:34
  • I did purge them with sudo apt-get purge nvidia* and then installed back nvidia-common. Checked /etc/modules for nouveau driver line, everything looks ok to me, but it does not work. – yad Dec 23 '15 at 16:14
  • nvidia-common is depreciated.. New version is sudo apt-get install nvidia-352 – Mark Kirby Dec 23 '15 at 16:16
  • It installed the driver but now I end up being in terminal. But at the first time of booting after installation I ended up in working Xorg. Xserver log file has this interesting line: drmSetMaster failed: Invalid argument – yad Dec 23 '15 at 16:25
  • So it worked once but now just a cli ? Try to roll it back, like this sudo apt-get purge nvidia-352 && reboot to make sure it is gone, then sudo apt-get install nvidia 340 – Mark Kirby Dec 23 '15 at 16:30
2

nvidia-common is depreciated in 15.04, you can use nvidia-352

First make sure that nvidia-common is completely removed

sudo apt-get purge nvidia* && reboot

Now install the newer driver

sudo apt-get install nvidia-352

Now run

nvidia-xconfig
sudo reboot

Now your desktop should load.

If you like the most up to date drivers for hardware, you can use this PPA

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-358
nvidia-xconfig
sudo reboot

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.