0

This question already has an answer here:

I recently installed Ubuntu 14.04 on a new, clean, Lenovo i5 Skylake Laptop.

The built in wifi adapter doesn't seem to be working. I used an Edimax stick, which was identified instantly, to access the web. Tried updating, upgrading, nada.

Any ideas?

lev@PC:~$ lspci -nn | grep -i net

Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15) 02:00.0 Network controller [0280]: Qualcomm Atheros Device [168c:0042] (rev 30)01:00.0 Ethernet controller [0200]:

marked as duplicate by Pilot6, Community Dec 23 '15 at 16:42

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Please, open a terminal window (Ctrl-Alt-T) then run the command lspci -nn | grep -i net, copy any text it shows, then paste it in your question. – Eric Carvalho Dec 23 '15 at 15:39
  • That worked! :) – Liev Kerzhner Dec 23 '15 at 16:39
0

I followed this: Qualcomm Atheros Device [168c:0042] (rev 30) Wi-Fi driver installation

Specifically the post by Jeremy31 that starts with:

You do not need Windows drivers and ndiswrapper

This has been recently fixed upstream, follow the instructions to install the backported modules and needed firmware

Worked like a charm. :) Thank you!

  • Welcome to Ask Ubuntu! ;-) Please don't answer by linking to other answers on this site, but use the [flag] button to flag the question as a duplicate (once you get a little bit more rep) ;-) – Fabby Dec 23 '15 at 22:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.