9

This what my display settings look like with the TV

So for a while I have had an old EMA 15" monitor hooked up to my Ubuntu machine running Ubuntu 15.04. The Monitor runs 1024x768 (4:3). At this point all is fine. But I hooked my computer to my Sansui HDTV and it will not let me have a 16:9 ratio so it is in letter box. How do I fix this?

NOTE: I am using a VGA cable between the TV and COMPUTER. Also I am used to Ubuntu and the terminal so please HELP!!!

$ sudo xrandr -q
Screen 0: minimum 8 x 8, current 1024 x 768, maximum 32767 x 32767
VGA1 connected primary 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768       60.0* 
   800x600        60.3     56.2  
   848x480        60.0  
   640x480        59.9  
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
6
  • Can you edit your post and past the results of sudo xrandr -q
    – chj1axr0
    Dec 23, 2015 at 2:53
  • With the TV or MOnitor connected? Dec 23, 2015 at 3:03
  • Yes with the T.V/Monitor connected
    – chj1axr0
    Dec 23, 2015 at 3:05
  • Im sorry I meant wihich one tv OR monitor. Dec 23, 2015 at 3:05
  • With the TV hooked up the one you are trying to get 16:9
    – chj1axr0
    Dec 23, 2015 at 3:10

3 Answers 3

14

Type this into your terminal: sudo cvt 1366 768. It will output something similar to:

# 1366x768 59.88 Hz (CVT) hsync: 47.79 kHz; pclk: 85.25 MHz
Modeline "1366x768_60.00"   85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync

Yours may be different than what I have, so copy everything after "Modeline" from your terminal.

Now paste in what you copied into this command, e.g. sudo xrandr --newmode "1366x768_60.00" 74.50 1280 1344 1472 1664 720 723 728 748 -hsync +vsync

The final step is to add the new resolution to the VGA1: sudo xrandr --addmode VGA1 1366x768_60.00

That should give you the resolution you want for the TV.

To keep the settings after restart use the answer here with your settings and you won't have to redo it.

21
  • this worked BUT my tv is weird it only accepts 1080 from some sources so could you change the code for 720 Dec 23, 2015 at 4:01
  • @dubCraftNation I have updated the answer for you to 720p 16:9
    – chj1axr0
    Dec 23, 2015 at 4:10
  • for some reson 720p is too small to fill whole screen but 1080 is not supported any suggestions? Dec 23, 2015 at 4:23
  • What is your model of Sansui HDTV?
    – chj1axr0
    Dec 23, 2015 at 4:27
  • 1
    @dubCraftNation I added a answer to a similar question for the answer to the restart problem
    – chj1axr0
    Dec 23, 2015 at 4:44
3

I added a 1504x846 res (16:9) for my Dell XPS since the highest it had was "1366x768".

cvt 1504 846 60
xrandr --newmode "1504x846" 104.50  1504 1592 1744 1984  846 849 854 878 -hsync +vsync
xrandr --addmode LVDS-1 "1504x846"

I then went to the "Menu -> Display" panel and picked it. profit!

note, run xrandr| grep primary to get your correct display name. Mine was "LVDS-1".

1
  • I am getting this error - Error of failed request: BadMatch (invalid parameter attributes) Major opcode of failed request: 140 (RANDR) Minor opcode of failed request: 18 (RRAddOutputMode) Serial number of failed request: 33 Current serial number in output stream: 34
    – AbhayBohra
    Nov 4, 2020 at 13:36
2

It sounds like you need to manually set your display resolution:

The settings are under Settings --> Displays. You need to set your resolution for that monitor to 1920x1080. See this YouTube tutorial.

8
  • It does not show that resolution I aded a link with picture. Dec 23, 2015 at 3:03
  • Hmmm, what's the output of ls /etc/X11?
    – Daniel
    Dec 23, 2015 at 3:48
  • There should be a config file in there that has a list of monitor modes.
    – Daniel
    Dec 23, 2015 at 3:50
  • 'code'$ ls /etc/X ls: cannot access /etc/X: No such file or directory Dec 23, 2015 at 3:50
  • See edit to comment
    – Daniel
    Dec 23, 2015 at 3:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.