7

I keep on seeing issues people are having with their wireless. I am having an issue with being wired into my router. I installed Ubuntu 11.10 the other day, on my custom PC. The motherboard I have installed on this PC is an ASUS P8H61-M.

The issue I am having is with my speed. I have a dual boot, windows 7 and the new Ubuntu. On my Windows install I am getting test speeds from Speakeasy at 17Mbps and actual downloads around 2-3MB/s. With Ubuntu, I am getting test speeds from Speakeasy at 1.14Mbps and actual downloads around 60KB/s.

I have disabled IPv6 and am no using GoogleDNS for my DNS, but it hasn't resolved the issue. I have scanned my router (WRT54GS Linksys) to disable IPv6 connections, and I am not seeing any option for that. I cannot figure out why I am getting such sluggish internet connection. Any help to resolve would be great!

I performed an iconfig -a with these results:

mark@Mark-ASUS:~$ ifconfig -a
eth0      Link encap:Ethernet  HWaddr f4:6d:04:d1:2c:4e  
          inet addr:192.168.1.103  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::f66d:4ff:fed1:2c4e/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:21888 errors:0 dropped:21888 overruns:0 frame:21888
          TX packets:21068 errors:0 dropped:90 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:26348337 (26.3 MB)  TX bytes:2217140 (2.2 MB)
          Interrupt:46 Base address:0xc000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:7 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:952 (952.0 B)  TX bytes:952 (952.0 B)

My specs are:

mark@Mark-ASUS:~$ sudo lspci -nn

04:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 06)
06:00.0 PCI bridge [0604]: ASMedia Technology Inc. Device [1b21:1080] (rev 01)

udev information:

KERNEL[11.351405] add      /devices/pci0000:00/0000:00:1c.2/0000:04:00.0/net/eth0 (net)
UDEV_LOG=3
ACTION=add
DEVPATH=/devices/pci0000:00/0000:00:1c.2/0000:04:00.0/net/eth0
SUBSYSTEM=net
INTERFACE=eth0
IFINDEX=2
SEQNUM=1542


UDEV  [11.363905] add      /devices/pci0000:00/0000:00:1c.2/0000:04:00.0/net/eth0 (net)
UDEV_LOG=3
ACTION=add
DEVPATH=/devices/pci0000:00/0000:00:1c.2/0000:04:00.0/net/eth0
SUBSYSTEM=net
INTERFACE=eth0
IFINDEX=2
SEQNUM=1542
ID_VENDOR_FROM_DATABASE=Realtek Semiconductor Co., Ltd.
ID_MODEL_FROM_DATABASE=RTL8111/8168B PCI Express Gigabit Ethernet controller
ID_BUS=pci
ID_VENDOR_ID=0x10ec
ID_MODEL_ID=0x8168
ID_MM_CANDIDATE=1

dmesg information:

[    2.855982] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
[    2.856366] r8169 0000:04:00.0: eth0: RTL8168b/8111b at 0xffffc9000064c000, f4:6d:04:d1:2c:4e, XID 0c900800 IRQ 46
[   12.540956] r8169 0000:04:00.0: eth0: link down
[   12.540961] r8169 0000:04:00.0: eth0: link down
[   12.541173] ADDRCONF(NETDEV_UP): eth0: link is not ready

I took out a lot of information that did not pertain to eth0, because the previous edits wouldn't save. If I need any more information, let me know. I would love to get this resolved. The other issue I am noticing is sometimes my connection disconnects all together, for about a minute, then it reconnects.

  • Hi Mark. I have Revision 3 of this network controller, using the same driver and it works flawlessly. I know that's not a very helpful comment but it might help if this turns out to be a Revision 6 specific issue. Btw, IPv6 shouldn't affect throughput, only the initial connection latency. I suspect this is more a problem with the driver and this particular version of the hardware. – Oli Nov 1 '11 at 12:23
  • I got the same problem and were not able to solve it as well. – JanD Apr 4 '12 at 12:42
2

I had the same problem with my Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06). Looking at the output from ifconfig you have a lot of dropped packages. Changing to a driver from Realtek worked for me:

Realtek 8168 module issue

I believe you have to do this every time you install a kernel update. Also note the comment from Jonathan on the same page.

| improve this answer | |
1

I have the same Ethernet adapter and have updated the drivers already but that didn't fix the issue. I tried disabling IPv6 and that also didn't help... but after some digging I found a reference to the /etc/nsswitch.conf file and changing the order of the "hosts:" line.

Originally, it was in the order

hosts:          files mdns4_minimal [NOTFOUND=return] wins dns mdns4

I changed it so that dns came after files and after rebooting the difference was night and day - DNS lookups are much faster and websites load immediately instead of being stuck at "Sending Request..." in Chrome (or doing nothing in FF).

hosts:          files dns mdns4_minimal [NOTFOUND=return] wins mdns4

I'm not sure if this will affect anything else negatively but I haven't had any problems with it since - I am able to browse my local network and mount Windows shares without any problems at all.

I hope this is helpful!

| improve this answer | |
0

I have unplugged my PC multiple times (transport) and it never resolved the issue. http://forum.ubuntuusers.de/topic/lan-karte-funktioniert-nicht/#post-3005217 is the website I used to resolve the issue.

| improve this answer | |
  • 1
    Welcome to Ask Ubuntu! It would be nice if you could find the website and post a more detailed explanation. – Octavian A. Damiean Feb 8 '12 at 23:37
  • I have now added the link. – Mark Feb 10 '12 at 11:48

Not the answer you're looking for? Browse other questions tagged or ask your own question.