19

Google Chrome, a web browser built for speed, simplicity, and security, runs terribly slow if I leave Chrome on for a several hours. It's like it is using a lot of memory though it is not. Tabs are very slow to load or switch between. CPU and RAM usage both appear to be normal. If I reboot Ubuntu entirely and then open Chrome, it runs fine. Editing /etc/nsswitch.conf made no difference. Hardware acceleration is on. Google Chrome Version 47.0.2526.106 (64-bit).

1
  • Anecdotally, I noticed Chrome ran a lot faster when a switched from X to Wayland.
    – Owen
    Mar 29 '20 at 16:02
39

Disabling "Use hardware acceleration when available" in

chrome://settings/?search=hardware

Fixed the problem.

7
  • This should be marked as the correct answer. The newer answers are saying the same as this one. Now chrome works like a snap for me. ubuntu 18.04. chrome 70.0
    – oma
    Nov 1 '18 at 10:54
  • 1
    We're now in 2019, and it seems Google fixed this issue ; I wouldn't follow this advice anymore.\ Sep 8 '19 at 1:36
  • 2
    It's still valid in Chrome 79 and Debian stretch
    – javsmo
    Dec 30 '19 at 12:58
  • 1
    This was a problem for Linux Mint 2021 as well - very long startup.
    – easyrider
    Jan 23 at 17:25
  • 1
    It is now June 2021, and I can confirm disabling this option fixes the slowness and long-lag between key strokes. I am using AMD CPU and Nvidia GPU, on Ubuntu 20.04.
    – Calleniah
    Jun 3 at 10:54
11

This seems to a bug with hardware acceleration and you can see the slowness when tab switching.

go to chrome://settings/?search=hardware

Disable hardware acceleration since it doesn't help:

Chrome Hardware Acceleration

6

Once I also faced the same problem. I searched for why Chrome is slow. My situation:

  • Chrome is not updated
  • Newly installed Ubuntu
  • Hardware acceleration is enabled

Here is a solution to this problem:

  • Update your Chrome

    sudo apt-get update
    sudo apt-get upgrade
    
  • Disable hardware acceleration chrome://settings/?search=hardware

1
  • Thanks for the solution. I use Linux Mint 19.3 in an old Toshiba satellite A-200. Chromium browser was very slow until I disable hardware acceleration and it became much faster. Nov 26 '20 at 9:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.