14

I've looked at various questions and threads and forums on this and nothing has worked.

I've been trying to mount a HDD that I have my linux games installed to. This drive worked flawlessly in the past but now Steam needs to find it again to say these games are installed. But when I try to add the appropriate folder I get this error:

New Steam library folder must be on a filesystem mounted with execute permissions

I've tried changing the folder name as suggested here and I've tried the solution here but run into a permission denied. Therefore I followed the steps here but am still running into permission is denied.

My question is what am I doing wrong and am I going about this correctly? How can I make steam see my games folder again? Any help is really appreciated.

I am running Ubuntu 14.04 and the drive location is /media/alkarin/Volume11

/dev/sdb2 is indeed ntfs

1
  • okay, I won't post as an answer as it needs some time to research, but I can give you advice for what to do*(or perhaps anybody else could elaborate)*. So, the NTFS filesystem does actually support unix-permissions. You just need to remount it with some option, and that's where you perhaps need to do some research. When you find that, and if that indeed solve the problem with Steam — you can modify the /etc/fstab to mount NTFS every time with the option.
    – Hi-Angel
    Commented Dec 22, 2015 at 17:58

5 Answers 5

11

This Steam error occurs because your drive is mounted by root and you don't have execute permissions on the drive (I think). You can use the disks app to change this.

Search disks in the dash, highlight your drive and under the usage image is a small cog icon, click this and edit mount options, now make your settings look like this

enter image description here

Leave the rest as it is and reboot. Now your drive can be found in /mnt and is auto mounted as your user at boot.

This is how I fix this error in 14.04, NTFS drive.

6
  • 2
    That did it. Thank you! And thank you for explaining why its not working as well.
    – Alkarin
    Commented Dec 22, 2015 at 19:53
  • 7
    This solution doesn't seem work in Ubuntu GNOME 17.04.
    – Rebel
    Commented May 1, 2017 at 4:25
  • 1
    worked on debian with ext4 drive too Commented Aug 6, 2020 at 15:33
  • This worked for me on Kubuntu. Of course I used "KDE Partition Manager" to do the task Commented Nov 9, 2020 at 11:57
  • I had to specifically set the extra mount options to defaults,x-gvfs-show to get it to mount with executable for Steam to load the games.
    – BookOfGreg
    Commented Jun 20, 2021 at 14:50
7

just got this error despite already having uid and gid set up properly as @delf answer; in my case windows left the "dirty bit", so i had to unmount it, run sudo ntfsfix -d /dev/sdb1 where sdb1 is your disk, and remount it.

2
  • 1
    Thank you so much, I never knew that windows could leave a dirty bit on the partition. Chosen answer did not help.
    – gkats
    Commented Oct 9, 2020 at 14:24
  • This worked for me, thanks!
    – Dan
    Commented Feb 4, 2021 at 16:57
5

For the logs: using ntfs-3g driver, the following minimalistic fstab did the trick for me

/dev/sdaX   /media/target-mountpoint    ntfs-3g defaults,x-gvfs-show    0   0

Hope that helps anyone :) Before i had forced uid and gid (to the user i was actually logged in with) and that didnt worked for some reason (i could create folders and files on the drive from a shell though, not sure what the problem was). So the options that didnt worked:

defaults,permissions,users,uid=1000,gid=33

(Yes, my host user has www-data as primary group)

2
  • did you try the "rw"-option with the ntfs-driver?
    – xcy7e
    Commented Jun 5, 2019 at 21:03
  • Same situation on Mint 19.3 (Ubuntu 18.04.1) - applied this solution and it worked. Thx!
    – sea212
    Commented Jun 17, 2020 at 19:11
4

The bug is a result of the 'users' fuse flag. I mounted the drive with the following fstab entry:

UUID=DRIVEUUID   MOUNTPATH   ntfs   errors=remount-ro,uid=1000,gid=1000,dmask=0027,fmask=0037,defaults   0 0

UID and GID are from my default non-root user, which I also use to start Steam as.

When you add the 'users' flag, you'll immediately get the mentioned bug.

1

I got this problem in Kubuntu 20.04. I am dual-booting Windows and Linux. Apparently Windows was setting the "dirty bit" as mentioned in the answer by Lesto.

I fixed it by disabling "Fast startup" in Windows as described here.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .