6

Trying to connect to SSH server using Ubuntu file explorer. I have already connected to that server using SFTP, but now I would like to do the same via SSH.

nautilus prompt

By entering address and pressing connect because of unknown reason it connects to recent connection via SFTP. Why not SSH? How to fix it?

  • are you able to connect it via terminal ? – rɑːdʒɑ Dec 22 '15 at 12:37
  • yes, I can connect via terminal – vico Dec 22 '15 at 12:43
  • What do you want to "fix" exactly? I don't think nautilus distinguishes between ssh and sftp (file transfer using ssh). Or are you trying to start an ssh terminal session from the file browser? – steeldriver Dec 22 '15 at 12:56
  • 2
    Isn't that exactly what SFTP does? – steeldriver Dec 22 '15 at 13:36
  • 1
    @AzkerM not all the time. Only if you don't remove `sftp subsystem, thought it is allowed on the most of the systems. – Jakuje Dec 22 '15 at 16:43
12

Did you read docs about Nautilus? There are examples of what should work. And from your tried, only this one is mentioned:

ssh://username@servername.example.com/folder

but it is automatically rewritten in "recent servers" to:

sftp://username@servername.example.com/folder

Basically, there is no ssh file transfer protocol. SSH is just Secure Shell or secure channel to pass data. If you want to transfer files, you need to use something built upon it. And sftp is the most commonly used protocol for doing so. The only more common is scp and it is too limited for remote filesystem mounts.

  • I'm not saying your answer is wrong, but could you explain it a bit better? It's confusing to others when you say that there is no such protocol, yet the page you are linking to has such an example. ;) – LiveWireBT Dec 23 '15 at 18:38
  • sorry. I wrote it too fast. I put the examples, observed behaviour and tried to improve it. Is it more understandable? – Jakuje Dec 23 '15 at 18:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.