51

I installed pip using get-pip.py after that pip freeze throws below error

Exception:
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/pip/basecommand.py", line 122, in main
    status = self.run(options, args)
  File "/usr/lib/python2.7/dist-packages/pip/commands/freeze.py", line 74, in run
    req = pip.FrozenRequirement.from_dist(dist, dependency_links, find_tags=find_tags)
  File "/usr/lib/python2.7/dist-packages/pip/__init__.py", line 299, in from_dist
    assert len(specs) == 1 and specs[0][0] == '=='
AssertionError

Storing debug log for failure in /home/simon/.pip/pip.log

So I checked 1.7 is the latest one. If I followed below steps and it's not updating... Help me here...

simon@simon-OptiPlex-780:~/Nightybuild$ pip --version
pip 1.5.6 from /usr/lib/python2.7/dist-packages (python 2.7)
simon@simon-OptiPlex-780:~/Nightybuild$ pip --version
pip 1.5.6 from /usr/lib/python2.7/dist-packages (python 2.7)
simon@simon-OptiPlex-780:~/Nightybuild$ pip install -U pip
Downloading/unpacking pip
  Downloading pip-7.1.2-py2.py3-none-any.whl (1.1MB): 1.1MB downloaded
Installing collected packages: pip
Successfully installed pip
Cleaning up...
simon@simon-OptiPlex-780:~/Nightybuild$ pip --version
pip 1.5.6 from /usr/lib/python2.7/dist-packages (python 2.7)
  • 1
    sudo -H pip3 install --upgrade pip – moldovean May 8 '16 at 10:09
53

I usually just run the following commands to upgrade both pip2 (=pip by default) and pip3:

sudo -H pip3 install --upgrade pip
sudo -H pip2 install --upgrade pip

You must make sure that you upgrade the version (for Python 2 or 3), which you want to react on the command pip without number, last.

Also please note that this keeps the old packaged versions installed through apt-get or any other package manager, but adds new versions which have nothing to do with the system packages. The pip-installed packages will be preferred, but you should not remove the apt-get-installed ones either, because the package manager can't know that any pip version is installed otherwise.

  • 3
    Why is it important to set home in sudo -H? – Léo Léopold Hertz 준영 May 28 '16 at 20:42
  • 11
    @Masi Because pip wants to write its downloaded files somewhere to cache them. It's implemented to place them in a subfolder of the current user's home directory. If you're running it without -H it will complain, because it detects that the currently set home directory (normal user) does not match the user it runs as (root). If it wrote its files in your home directory, they would be owned by root and not accessible to you as normal user any more. Therefore it does not cache the files in this case. It's not terrible to omit the -H as pip detects it and warns you. – Byte Commander May 28 '16 at 20:47
  • 1
    Why do both the commands just overwrite the pip command? When I upgrade pip2 it doesn't upgrade the pip2 command, just pip. – Yep_It's_Me Oct 18 '17 at 8:30
  • @Yep_It's_Me this is because pip is relative to which version of python you are calling. and is why his commands are pip2 & pip3 respectively call the appropriate version of python to update pip. Does that make sense? – JayRizzo Jan 20 at 4:30
26

I think the

pip install --upgrade pip

command does not work properly any more. The correct command should be:

  • for Python 3:

    python3 -m pip install --upgrade pip
    
  • for Python 2:

    python2 -m pip install --upgrade pip
    
  • Gg @david-foerster – JayRizzo Jan 20 at 15:40
  • On Linux, just use pip install -U pip (see Upgrading pip) – Eido95 Mar 24 at 9:53
  • 1
    I had problems when updating pip from root (in a Docker image) and this worked like a charm. – Cristian Ramon-Cortes Jun 6 at 15:29
  • Worked like a charm on Linux mint – HelloWorld Jun 13 at 13:01
5

Go to this website https://pypi.python.org/pypi/pip

copy (or) download the source link (ends in .tar.gz)

for 9.0.1 the link is https://pypi.python.org/pypi?:action=show_md5&digest=35f01da33009719497f01a4ba69d63c9

installation procedure

wget //link goes here
tar -xzvf pip-9.0.1.tar.gz
cd pip-9.0.1
sudo python3 setup.py install

the version should be changed to the latest version and the link can be updated with the latest version's link

this should work

  • this is the only thing that worked for me since everything else needs a connection to the server from the shell, which again fails with the same error. – Alok Rajasukumaran Aug 12 at 11:13
1

pip install -U pip

The shortest I know.

1

I think it's worth mentioning that what I'm explaining below is if you expect pip to point to Python 2 and pip3 to point to Python 3. The reason I mention this is because when you upgrade pip3, it also takes over the pip command as well. This is a somewhat strange convention because by default python points to 2.x and python3 points to 3.x. That being said...

If you want to have the latest versions of python 2.x pip and python 3.x pip3 coexist on the same machine (using pip for 2.x and pip3 for 3.x), you need to do the following:

sudo apt-get install python-pip python3-pip --yes
sudo python3 -m pip install pip --upgrade --force
sudo python -m pip install pip --upgrade --force # this line associates pip with Python 2

The other answers provided by others fail to mention that after running sudo pip3 install pip --upgrade you'll end up with the pip command installing packages in the python 3.x directories instead of the python 2.x directories.

Part of me thinks that we should just leave pip be after upgrading pip3 (even if it pip -> pip3), but there's a danger there that people already have an expectation that pip functions like python - both pointing to python 2.x. In other words, people are probably trained to use pip/python for python 2.x just like they are trained to use pip3/python3 for python 3.x.

0

I face same error and resolved it with following commands.

sudo su root
apt-get purge -y python-pip
wget https://bootstrap.pypa.io/get-pip.py
python ./get-pip.py
apt-get install python-pip

ImportError: No module named packaging.version

  • apt-get purge -y python-pip worked for me – Akira Yamamoto Jul 25 at 6:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.