5

I'm trying to use nx to login remotely to my desktop. But when I do, because of unity I get the following screen:

My NX Client

It looks like all I can do is access the file browser from here. I tried following the instructions in this post, but they don't work (presumably because I don't have the necessary gnome stuff). How do I launch the unity-2d "session" on 11.10?

7

You use gnome-session --session=ubuntu-2d as the command in your NX client.

  • As I said in my question above, doing this does not work. – Kurtis Nusbaum Oct 24 '11 at 1:29
  • 3
    You know, I'm not the kind of guy who guesses without saying so. Before I wrote that answer, I tested it myself. Perhaps you should consider updating your answer to provide more details? – Jo-Erlend Schinstad Oct 24 '11 at 3:29
  • Thank you for your patience. I tried it again and it's working now. I'd reversed the phrases and had typed in 2d-ubuntu instead of ubuntu-2d – Kurtis Nusbaum Oct 24 '11 at 4:07
  • 1
    Glad to hear that :) – Jo-Erlend Schinstad Oct 24 '11 at 4:27
  • I wasn't sure where in the NX client to enter this command. See the following answer for more details: askubuntu.com/questions/69522/… – Ben McCann May 1 '12 at 16:43
2

The problem is described on this nomachine webpage.

I had to check which sessions are available for gnome-session in /usr/share/gnome-session/sessions and modify the session startup (--session=gnome-classic changed to --session=gnome).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.