There are many ways to mount an SMB share in Ubuntu. For example:

  • as root, you can use mount.cifs:

    mount -t cifs -o user=username //servername/sharename/ /mnt
  • you can use smbnetfs as described here

However, I would like to use gvfs. When logging in using ssh. I tried the following without a success:

dbus-launch bash
gvfs-mount smb://servername/sharename/

This works... kind of. When I run

gvfs-mount -l 

I get the following:

Mount(0): sharename on servername -> smb://servername/sharename/
  Type: GDaemonMount

So, the mount seems to work. However, there is no file system mount point, whereas when I mount it using Nautilus, I get a mountpoint in /run/user/1000/gvfs/, which I can then access using command line.

What should I do to get a mount point with gvfs which I can access with the command line?


The mount point should be in ~/.gvfs. At least by me it was there with this name: smb-share\:domain\=WORKGROUP\,server\=\,share\=asmedia-hdd\,user\=root/. If you still cannot find it, you can try sudo find / -name sharename -type d. Maybe it finds the directory somewhere else. Another possible location is /run/user/1000/gvfs.

| improve this answer | |

At least with Ubuntu 18.04, the following works:

$ gio mount smb://<server>/<share>
Password required for share <share> on <server>
User [<user>]:
Domain [<workgroup>]:

The mount points are located in /run/user/<uid>/gvfs/ (idem $XDG_RUNTIME_DIR/gvfs).

| improve this answer | |
  • For unattended mount with username/password/workgroup try this. Then you can create a symlink to whatever with eg ln -si $XDG_RUNTIME_DIR/gvfs/mysmbmount $HOME/smb – Pablo Bianchi Jan 13 at 16:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.