0

I have screwed up my Ubuntu 14.04 installation and need to reinstall. I have my data backed up online, so it's no problem to completely wipe out. However, I also have a Windows partition, recently upgraded from 8.1 to 10 (this was not the cause of my Ubuntu problems), so I can't just format and install to the whole drive (a 512GB SSD). I have done a lot of searching, but haven't seen an answer that quite covers my situation.

I have no optical drive, so to get grub2 to allow me to load the Ubuntu iso, I used grml-rescueboot, and when I power up, I can Grml Rescue system, and it's like I'm using the live CD.

The first question I am asked is "Unmount partitions that are in use?" with information: "The installer has detected that the following disks have mounted partitions: /dev/sda" and tells me that I won't be able to create, delete, or resize partitions, which is fine with me. So I told it "no" do not unmount the partitions.

Next is asks me to choose the Installation type. I first tried the "Erase Ubuntu 14.04.3 LTS and reinstall," but got hung up on the first step of "detecting system" (or whatever it said...). This seems to be a common problem, so I decided to go with "Something else" for the installation type.

Here I select the Ubuntu partition /dev/sda8, push "Change" and tell it to use it as ext4, format the parition, and make it mount point /. I select another partition, /dev/sda7 and tell it to use as swap area.

Device for boot loader installation is set to (by default): /dev/sda, which is the whole drive.

When I click install, it gives me a warning that this will destroy data on the partition to be formatted, and tehn tells me that the partition tables of the following devices are changed: SCSI2 (0,0,0) (sda).

When I click Continue, it says it "Failed to unmount paritions," explaining that "the installer needs to commit changes to partition tables, but cannot do so because on the following mount points could not be unmounted: /isodevice"

So, my question is: how do I proceed now? Is the problem that I can't install Ubuntu from the iso mounted on the hard drive? If it helps, here is some more information on my partitions:

sda1: 500MB (EFI)
sda2: 40MB
sda3: 128MB
sda4: 490MB (WINRETOOLS)
sda5: 255GB (Windows)
sda6: 463MB
sda7: 15GB
sda8: 189GB (Ubuntu)
sda9: 7.45GB (Recovery)
sda10: 8GB (OEM)

0

I solved it by using umount on the iso, as described here: https://help.ubuntu.com/community/Grub2/ISOBoot

sudo umount -l -r -f /isodevice
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.