0

I'm using Ubuntu Server 14.04 and have several external storage arrays (nothing special a 5 disk RAID10 box, they appear to the OS as a single disk) I use the UUID to mount them with /etc/fstab because I understand that the OS can assign different /dev/sdx letters to disks upon reboot and I need each one mounted at the same point each boot. Everything mounts fine on boot up but often later (a few days or weeks maybe) the files mounted at the location will "disappear" and not show up until the next reboot. After investigating I've found some inconsistencies, I just do not know what would cause them, below is what I've found.

/etc/fstab:

UUID=24ce55a6-58c6-4f91-a7fd-f602c87dae77       /data-mount         ext4    defaults,rw     0       0

blkid -c /dev/null:

/dev/sdc1: UUID="24ce55a6-58c6-4f91-a7fd-f602c87dae77" TYPE="ext4"

df -h:

/dev/sdb1                     7.3T  2.7T  4.3T  39% /data-mount

dir /data-mount:

dir: reading directory .: Input/output error

Sometimes I can run the dir command and get data on the disk...I don't understand why it shows mounted as /dev/sdb1 when using df but blkid shows it as /dev/sdc1. I'm not sure what I have wrong but I have 4 of these RAID10 devices and only one doesn't seem to do this but they are all configured the same way as far as I can tell, I'm just looking for ideas on how to fix this.

Thanks, Luke

0

It looks like the external devices are falling offline and then when they come back are added as a different device.

Have you tried to use labels instead?

http://www.cyberciti.biz/faq/rhel-centos-debian-fedora-mount-partition-label/

  • Thanks for the tip! I changed them to mount using labels, I won't know for a little while if it worked but will mark it answered in a week or so if there is no trouble. – LHIGGS Dec 22 '15 at 14:23
  • Sorry for the late response. The problem persists using labels or UUIDs to mount with fstab. I've also set a cronjob to update a file with the date and time every minute so it's not a issue of the drives "going to sleep". The drives seem to go offline then come back online and are assigned a different /dev/sdx ID. – LHIGGS Jan 11 '16 at 14:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.