13

Is there any way to force grub menu to show it's content in external monitor (for selecting the os to boot on win or ubuntu), I use my laptop more like a desktop with a monitor connected to it because of broken laptop fan socket. Either HDMI or VGA would work.

3
  • 1
    Can you set the bios of the laptop to display on an external monitor ? That should do it for grub too. This is the only real solution I found on Google, but not all laptops have this option. – Mark Kirby Dec 21 '15 at 20:57
  • Mine doesn't have that :( #hatelaptop – biozalp Dec 21 '15 at 20:58
  • OK Might of got lucky with this, I assume, because of overheating you would be fine with not having the laptop display on when the desktop boots, right ? – Mark Kirby Dec 21 '15 at 21:20
4

Here is a bad way to do this, for most, that may just be good for you.

On desktop, open this file as root

gksu gedit  /etc/default/grub

and find this line

GRUB_CMDLINE_LINUX_DEFAULT=...

and add a this to the end

video=LVDS-1:d

my whole line is

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

so I would add it here

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video=LVDS-1:d"

Change lvds-1 for you monitors name, if it is different, find it with

xrandr -q

Save and exit, and run the command

sudo update-grub

This will disable the Laptop display for both grub and the desktop and force it to the external display, even if you remove the HDMI cable, the laptop screen will not work. You can remove the change to change it back to using the laptop screen.

I can't test this as I don't have a laptop, but I took it from an question at arch, where the issue was no laptop display after forcing grub to an external monitor.

I don't recommend this for most users who want there laptop to still be portable.

5
  • will give it a try and come back asap. – biozalp Dec 22 '15 at 20:23
  • 2
    I tried this but it did not work: the menu is not displayed on the external monitor. The external monitor is only activated after Linux has booted. – Giorgio Sep 28 '16 at 19:54
  • I just dealt with the same problem and the answer by @Mark Kirby helped a lot! For me it was essential to replace LVDS-1 with the name of the built-in laptop screen provided by xrandr -q. I would additionally advise to run sudo update-grub after you made the changes and before you reboot. – Felix S. Oct 17 '20 at 16:37
  • @Mark could you precise what is the d in LVDS-1:d? By the way, if you have time, I asked a related question in askubuntu.com/questions/1286892/… Thanks!! – Matifou Oct 25 '20 at 21:28
  • @Matifou I am not 100% sure because this was a while ago and I can't find any documentation right now but I think d is for "disable" and using e would be "enable", so LVDS-1:d would disable the laptop display. – Mark Kirby Oct 28 '20 at 20:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.