0

Let me explain my situation.

I use UBUNTU 14 and it is regularly updated.

I downloaded the Arduino 1.6.6 compressed file from Arduino.cc for Linux.

I extracted it in the home folder.

I run Arduino by double clicking on the by default executable arduino file. Arduino launches and all is fine.

UBUNTU automatically shows a launch icon in the UNITY bar on the left. Every modern UBUNTU user knows this UNITY bar.

I lock the Launcher in the UNITY bar by right clicking on it and choosing "Lock to Launcher".

I close Arduino by choosing 'Quit' in the 'File' menu.

Then comes the unfortunate observation: When wanting to launch from the UNITY bar by clicking on the locked Arduino Launcher in the bar the Arduino splash shows and immediately disappears and nothing happens.

Bugger!

Why is that?

PS: No terminal tricks, did them all, none worked. Arduino launches from everywhere except from the UNITY bar having locked the presented icon after regular successful launch via directly double-clicking the executable Arduino file.

0

Dashes and dots (periods) in filenames, foldernames and paths confuse the UNITY launcher.

Here is the contents of arduino.desktop:

[Desktop Entry] Type=Application Name=Arduino IDE Atmel GenericName=Integrated Development Environment Comment=An IDE for Arduino-compatible electronics prototyping platforms Exec=/home/benoit/arduino-1.6.6/arduino Icon=/home/benoit/arduino-1.6.6/lib/arduino.png Terminal=false MimeType=text/x-arduino Keywords=embedded electronics;electronics;avr;microcontroller;

Look at the Exec=PATH/arduino and Icon=PATH/arduino. They contain dashes and dots (periods) and this caused the problem.

The solution I found is to rename the folder which contains the extracted Arduino package in which among other files the arduino.desktop and executable arduino file reside. I did this by using a text editor, opening the arduino.desktop file and making the proper corrections to it to become like this:

[Desktop Entry] Type=Application Name=Arduino IDE Atmel GenericName=Integrated Development Environment Comment=An IDE for Arduino-compatible electronics prototyping platforms Exec=/home/benoit/arduino/arduino Icon=/home/benoit/arduino/lib/arduino.png Terminal=false MimeType=text/x-arduino Keywords=embedded electronics;electronics;avr;microcontroller;

Now the Exec=PATH/arduino and Icon=PATH/arduino do not contain dashes and dots (periods) anymore.

I also made sure arduino.desktop is allowed to be executed as program via right clicking its name, choosing 'properties', then 'permissions' and setting the option 'Allow executing file as program.' below.

This solved my own problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.