I cannot use the user the gnome-shell-extensions-user-theme because there is no button on the tweak tool to enable extensions! I've completely uninstalled and reinstalled the gnome-tweak-tool, no difference. Any suggestions? Bruce.


I had the same problem. Seems that the file metadata.json has a wrong shell-version. At least for Ubuntu 11.10. To solve the issue I had to:

  • cd ~/.local/share/gnome-shell/extensions/
  • cd into the desired extension directory.
  • edit the metadata.json file and change
"shell-version": [ "3.3.2" ] 
"shell-version": [ "3.2" ],
  • logout from Gnome-Shell and login again. Now you should see all the estensions in gnome-tweak-tool.

This is a weird answer.. after a clean installation of Ubuntu 13.04 i realized that neither the gnome.extensions.org works (all the extensions are greyed out) nor the Gnome Tweak tool worked..

I tried following many steps (and reverting them). The simplest was to go back to the Login page and change the desktop manager from the default Ubuntu to Gnome.. That fixed all the issues.

Hope this helps.


I had now same problem but on my Debian 9 fresh installation.

Check if your ~/.local/share/gnome-shell/extensions/{extension directory}/metadata.json have 664 permissions. I had 400

After chmod 664 ~/.local/share/gnome-shell/extensions/{extension directory}/metadata.json it shown correctly in gnome-tweak-tool


Had the same problem 10 minutes ago :D. This very brief command saved the day:

sudo apt-get remove fglrx*

It purges all installations and references for the proprietary graphics driver and once you restart gnome-shell, 3D acceleration is re-enabled and gnome-shell plus other applications requiring 3D acceleration run properly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.