I don't understand why this issue could be survive. It display this error message all the time

Fetched 32.8 MB in 1min 16s (430 kB/s)                                         
W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/trusty-security/main/binary-amd64/Packages  Hash Sum mismatch

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/trusty-security/universe/binary-i386/Packages  Hash Sum mismatch

E: Some index files failed to download. They have been ignored, or old ones used instead.

I was tried to using these commands (which found in this question)

sudo apt-get clean
sudo rm -vf /var/lib/apt/lists/*
sudo rm -vf /var/lib/apt/lists/partial/*
sudo apt-get update

No luck for me. That dump message show up again. Always failed with security.ubuntu.com. My internet connection is OK, I'm able to ping to security.ubuntu.com without any trouble.

So, the question here is why? And anyone out there can help me out of this? I'm going to crazy!

  • How long has this been going on?
    – Seth
    Dec 21, 2015 at 2:40
  • @Seth: 3 days ago, and this moment. Dec 21, 2015 at 2:40
  • 1
    Usually it is just a temporary problem with the server and disappears after a few minutes or few hours.
    – Seth
    Dec 21, 2015 at 2:47
  • Have you recreated /var/lib/lists and its subdir /var/lib/lists after removing them? Try to do it and fetch the lists again sudo mkdir -p /var/lib/apt/lists/partial
    – Tung Tran
    Dec 21, 2015 at 3:13
  • -Seth: Yes, sometime the issue gone, but it always came back to find me.... -TungTran: Did you really read my question? If you really do read it, you will not ask that question. Dec 21, 2015 at 3:30

5 Answers 5


Configure your proxy in network settings of your PC for each of items like HTTP, HTTPS, FTP and Socks and apply settings to system wide if you are using proxy.

Remove the existing packages and then try as follows:

apt-get clean
rm -rf /var/lib/apt/lists/*
apt-get clean
apt-get update 
apt-get upgrade

(copied from above message)


This worked for me:

 apt-get clean
 rm -rf /var/lib/apt/lists/*
 apt-get clean
 apt-get update 
 apt-get upgrade
  • 1
    I had to # mkdir /var/lib/apt/lists/partial after this
    – Jacksonkr
    Dec 9, 2016 at 18:30

I have Ubuntu 14.04 LTS, and sometimes when I use this command, I encounter with this problem. For solving this you can use the following way:

  1. please go to system settings.

    system setttings

  2. click on software & updates

    software & updates

  3. go to other software section. You can find the links that are relative to this error. Uncheck the relative links and click close. If you can't find relative link you can go to ubuntu software section and uncheck options that may can relative to this error. Sometimes with changing Download Server to Main Server your problem can be solved. For changing download server you can go to ubuntu software section and change Download From and choose Main Server.

  • 1
    I appreciate your helps, but this absolutely give me no helps. Switch to main server is just simple edit file in /etc/apt/sources.list from xx.archive.ubuntu.com to archive.ubuntu.com. Why? Try to ping archive.ubuntu.com and security.ubuntu.com, they must return you same IP address. Feb 4, 2016 at 9:39
  • how do i get to system settings from the command line via ssh -X? Dec 31, 2018 at 18:47
  • Step 3 solved the "failed to fetch" problem of the "APT repository for D" on my Ubuntu 14.04. The error message was "gnutls_handshake() failed: Handshake failed". apt-get update works fine after I uncheck the problematic repository.
    – HD189733b
    Nov 24, 2019 at 19:30

I had a similar problem a week or two ago, and it turned out to be a DNS problem. I edited my static configuration in /etc/network/interfaces and changed the DNS entry to Googles DNS with:


Then rebooted.

  • I tried this one first, it worked for me! thanks!
    – Chan Kim
    Jan 29, 2019 at 8:12

Please navigate to


then open the sources.list file

sudo -H gedit sources.list

then remove the broken or unavailable package link and save.

Then add a valid one.

  • 2
    It can be quite challenging to "add a valid one" since the formatting of lines in source files is quite strict, and we may not know where to find the new or correct repository. It may be better to use tools like add-apt-repository to do this.
    – Zanna
    May 30, 2020 at 8:39

Not the answer you're looking for? Browse other questions tagged or ask your own question.